Jump to content

Error 2597

Recommended Posts

Error 2597 Good everyone, I have reinstalled Windows and Rad Studio Alexandria, what used to work, the build for Android at 32 and 64 bit, now does not compile, I have tried with different versions of SDK and always shows me the same error:

[DCC Error] E2597 c:\program files (x86)\embarcadero\studio\22.0\lib\Android\debug\SysInit.o: error adding symbols: File in wrong format.




  • Like 1

Share this post

Link to post



Try making a copy of the SysInit.o and delete it from the folder that you are getting the error.


What seems to me rare is that is doing a compile in such folder c:\program files (x86)\embarcadero\studio\22.0\lib\Android\debug\


Also when compiling trying running first Delphi as Administrator.

Share this post

Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now