Jump to content

IBLite "product INTERBASE is not licensed" Exception after Delphi Rio 10.3.3 Update

Recommended Posts



After upgrading to Delphi Rio 10.3.3, I have an issue with IBLite licensing on Android devices (haven't checked on iOS). The issue is the following. When a user downloads the app for the first time, it runs perfectly fine. When they update the app (if they have it already installed on their phone), they get the "product INTERBASE is not licensed" exception. In the same way, during development, if I do a "clean install", everything works fine. If I don't I'm getting the same error.


Most probably, there is a file on the existing app that is not being overwritten during the update because it is newer then the file on the updated app. The files needed for IBLite are the following: 


- reg_iblite.txt

- ibconfig

- admin.ib

- license.txt

- oss_license_notice.txt

- interbase.msg


I even changed the date on my PC, modified the files above to have a future datestamp and tried again. Same error.


Is there something I'm missing?


Kindly advise

Share this post

Link to post

I changed my Interbase connection from IBLite to IBTogo. Now, if I run the app without the "-cleaninstall" in the Run parameters, it works fine on the device. If I create a bundle (32 & 64-bit) and upload it to the Google Play Store, I'm getting the same error: "product INTERBASE is not licensed". Have in mind that this is ONLY if the app is already installed and is updating; not when the user is installing it for the first time.


I'm out of ideas.

Share this post

Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now