Jump to content
Kyle Miller

MARS & Delphi 10.2

Recommended Posts

I tried the latest release. Several build failures during install. I noticed commits address the issues, so I pulled the head. It installs.


Trying to build MARSHelloWorld & it's complaining of numerous items missing in SynTable.pas. It may be affected by me commenting out {$I MARS.inc} in Server.Forms.Main because the inc file is not included. I tried using the one in C:\Development\ExtLib\MARS\Source to no avail.


Do I need to install mORMot to use MARS?



Share this post

Link to post

Never mind. Removed a reference to an Delphi MVC Framework installation I wasn't using. It was the source of conflict.

  • Like 1

Share this post

Link to post

Thanks, I am using a portion of mORMot (check my mORMotJWT repository: https://github.com/andrea-magni/mORMot-JWT) I have extracted (with permission) in order to benefit of their JWT implementation (that is way better than the JOSE implementation). Unfortunately, they are (were?) not supporting Linux compilation with Delphi because of ARC. That's the reason I still have JOSE and mORMotJWT support at the same time.


Glad you solved!




  • Like 1

Share this post

Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now