Jump to content
Stéphane Wierzbicki

CEF4DELPHI - How to get permisions to use Webcam and Microphone ?

Recommended Posts



I'm playing with CEF4DELPHI and I'm not able to get access to my Webcam nor to my microphone (test on 'https://webcamtoy.com' ).



  GlobalCEFApp                          := TCefApplication.Create;
  GlobalCEFApp.MultiThreadedMessageLoop := False;
  GlobalCEFApp.ExternalMessagePump      := False;
  GlobalCEFApp.EnableMediaStream := True;
  GlobalCEFApp.EnableSpeechInput := true;
  GlobalCEFApp.EnableGPU := true;
  GlobalCEFApp.UseFakeUIForMediaStream := true;
  GlobalCEFApp.OnContextInitialized     := GlobalCEFApp_OnContextInitialized;


Has anyone a clue on how to solves this ? I need maybe to add the URL to a trustee web site list ?




Ps: tried to ask this question on CEF4DELPHI but I'm not able to register !


Share this post

Link to post



I added GlobalCEFApp.EnableMediaStream := True; to the DPR file of the SimpleBrowser2 demo and I could see the video from my cheap webcam in webcamtoy.com


About the registration issue, send me a PM with your username and I'll activate it manually.

  • Like 1

Share this post

Link to post
Posted (edited)

After reading your code again I see that you're disabling the GlobalCEFApp.MultiThreadedMessageLoop property.


It's recommended that Windows applications keep GlobalCEFApp.MultiThreadedMessageLoop enabled.

Only in some cases you can consider disabling it but then you should use a "External Message Pump".

Edited by salvadordf

Share this post

Link to post
Posted (edited)
1 hour ago, salvadordf said:

About the registration issue, send me a PM with your username and I'll activate it manually.

Hi Salvador,


Thank you for your help but I received my confirmation email a couple of hours later and was able to confirm my account 🙂


What I'm basically trying to achieve is to create a client that will directly connect to spaces.avayacloud.com.


I'm still not able to get my webcam and microphone detected. 


Edited by Stéphane Wierzbicki

Share this post

Link to post

Check these points :

  • Assuming you use Windows 10, check if you can make that camera work with the "Camera" app.
  • Install Chrome or Chromium 84. Ideally you should try to install 84.0.4147.89 and make the camera tests with the latest CEF4Delphi version from GitHub. Test your camera with Chrome/Chromium on webcamtoy.com.
  • Open the SimpleBrowser2 demo and add GlobalCEFApp.EnableMediaStream := True; before the GlobalCEFApp.StartMainProcess call in the DPR file. Connect your camera, build the demo and test it in webcamtoy.com

If your camera works on a similar Chrome version then it should work with the SimpleBrowser2 demo or any other CEF application.

Share this post

Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now