Jump to content

Limited GExperts support for Delphi 6

Recommended Posts

A few weeks back something happened with my Delphi 6 installation which now results in an access violation every time I start the IDE. I tried for several hours to find and fix the problem to no avail. It’s not GExperts related, disabling the DLL was the first thing I tried. Now I’m giving up. This will mean that while GExperts will still continue to support Delphi 6 and I will compile a dll with every release (as long as the command line compilation still works), I will not be able to debug and fix any issues.

If you are still using Delphi 6 you are invited to take over this task.


read on in the blog post

Share this post

Link to post

I have similar problems with D6.  I haven't been able to nail down exactly what causes the exceptions on startup though.  Are you saying that removing/deinstalling the GExperts DLL fixed the problem? 


I have tried deinstalling GExperts and the instability remains.  I put it back since it is too valuable a tool for me - and suffer along with many IDE crashes per day.


Most of the exceptions I see that occur upon startup can be ignored.  It sometimes helps to launch D6 as a local administrator.  


Do you have any insight into what the problem might be, other than what you stated in your post?


Share this post

Link to post


I've been using GExperts with Delphi 6 for a long time now, and everything worked nicely so far. I've updated it every time a new version came out, by using your installer (keeping the settings). That was up to version 1.3.18 (included).

The new version, 1.3.20, causes the Delphi 6 IDE to either crash with an error message upon start (when I had the previous GExpert settings) or to suddenly (after a few seconds from starting) exit to desktop with no message at all (that was after I cleared all GExpert settings from the registry). Weird.

I went back to 1.3.18 for Delphi 6, with no issues. 1.3.20 works fine on Delphi 10.4.2 by the way.

I didn't make any changes to Delphi 6 IDE (e.g. no new components). I've had it setup as it is now for quite some time.

I didn't yet try it, but does it seem plausible that it might just work if I compile GExperts myself? I've already read on your blog post that you've hit a dead-end with debugging the issue.


Kind regards

Share this post

Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now