Jump to content
The Stranger

[RESOLVED] Which SDK should I use if I want to develop an Android app on Delphi 10.3 Rio?

Recommended Posts

Posted (edited)

Hi all, I'm looking to distribute my android app on play store using Delphi 10.3.

I know I should upgrade to Delphi 11, but trying to compile the app in the new version I'm stuck in a number of memory or compilation issues.

 

When on Delphi 10.3 I try to start the project deployment I always get the same error "[PAClient Error] Error: E0002 Missing profile name; use paclient -? For Help".

I tried to use various versions of the SDK: I tried 26, 28, 29 and even 30 but nothing.

When I compile it in development mode both in debug and in release I can load it on my smartphone with Android 10, while compiling it in Release and Application Store mode I get the error mentioned.

 

Some idea? Thanks in advance

Edited by The Stranger

Share this post


Link to post

Resolved.

For all those who need it this is the solution:

 

However, the times are moving on. Delphi 10.3 supports SDKs up to 28, while 10.3.3 supports SDKs up to 29. Google wants the SDK to be 30, so the advice is to upgrade to a higher version of delphi right away.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×