Jump to content
Paolo Pedrielli

Delphi 11.2 iOS Simulator libmidas.a libsqlite.a missing

Recommended Posts

Hi all,

I'm trying to deploy my app to iOS Simulator.

I have an M1 Pro Mac and the app compiles without issues.

But, when it try to deploy, it hangs says 'libmidas.a' missing.

I searched in lib folder, in iossimarm64\release folder and it doesn't exists! Also missing sqllite.a!

I copied them from iOSDevice64 but it doens't work.


Do you have these files in our lib folder?





Share this post

Link to post

Hey Paolo,

Did you ever find a solution?

I got the same error message:

[DCC Error] E2597 ld: file not found: libmidas.a

To me it looks like this problem appeared in 2013 as well, when Marco Cantu fixed it with a hotfix:


In my case the app works great on my device, just not on the simulator.


Share this post

Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now