Jump to content
Incus J

Windows App Store icon sizes - unplated?

Recommended Posts

When I create and run a Windows Store App, my application icon looks very small on the taskbar, compared to other application icons.  It appears to be surrounded by a grey background too, instead of transparent.


After reading around a bit, I suspect I'm getting a 'plated' icon.  How can I get an 'unplated' app icon instead?


I'm using Delphi Rio 10.3 to generate the appx file, and have provided the required UWP 44x44 and 150x150 icons, in addition to the main app icon (which contains 16x16, 24x24, 48x48 and 256x256 images) in Delphi's Options.

Share this post

Link to post

As an experiment I just tried adding a separate copy of the UWP 44x44 icon to the Project Deployment Manager.


I named this copy with the extension '.targetsize-44_altform-unplated' as suggested in Microsoft's documentation.  Then I set its Remote Path to 'Assets\' so it would appear in the Assets folder, and built the app.

No joy - perhaps because the auto-generated AppxManifest.xml file does not contain a path to that icon filename.  When the app is run, its Task Bar icon is still very small and surrounded by a grey 'plate'.  But maybe I'm heading in the right direction.  Anyone have any ideas?  Perhaps Delphi includes an option to customise the generated AppxManifest.xml file somewhere?

Share this post

Link to post

Experiment 2 : In the Project Deployment Manager, simply rename the Remote Name of the original existing 44x44 icon so it ends '.targetsize-44_altform-unplated'.  Rather than trying to provide an additional 44x44 icon.


OK that's more promising - the newly generated AppxManifest.xml icon entry matches the renamed file in the Assets folder:

<uap:VisualElements ... Square44x44Logo="Assets\Logo44x44.targetsize-44_altform-unplated.png" .../>


...but unfortunately the deployed app still runs showing a tiny plated icon in the Task Bar.

Share this post

Link to post

@Rafael Dipold have you done something different than in that article? It isn't working for me.

I didn't used Delphi IDE because it's calling makeappx.exe with /f (mapping file) and I used /d (content directory)

I have the same file with two names in Assets: Logo44x44.png and Logo44x44.targetsize-44_altform-unplated.png

The Root folder is every time new created and filled with all necessary files then:


C:\Delphi\WA15\WinArhi\!Executabil Showroom\UWP\Root>"C:\Program Files (x86)\Windows Kits\10\bin\10.0.22621.0\x86\makepri.exe" createconfig /cf priconfig.xml /dq en-US       
'Platform (pv)' not specified. Default is Windows 10.

Writing PRI config file to priconfig.xml ...

Successfully Completed

C:\Delphi\WA15\WinArhi\!Executabil Showroom\UWP\Root>"C:\Program Files (x86)\Windows Kits\10\bin\10.0.22621.0\x86\makepri.exe" new /pr "C:\Delphi\WA15\WinArhi\!Executabil Showroom\UWP\Root" /cf priconfig.xml
Output location of PRI file(s) is detected to be under the project root. If previously generated PRI file(s) are present, these may be re-indexed and lead to unexpected results.

Index Pass Completed.

AlternateForm Qualifiers: UNPLATED

TargetSize Qualifiers: 150,44


Finished building

Version: 1.0

Resource Map Name: winarhi.winarhi15s

Named Resources: 27


Resource File: resources.pri

Version: 1.0

Resource Candidates: 29

AlternateForm Qualifiers: UNPLATED

TargetSize Qualifiers: 150,44


Successfully Completed


C:\Delphi\WA15\WinArhi\!Executabil Showroom\UWP\Root>"C:\Program Files (x86)\Windows Kits\10\bin\10.0.22621.0\x86\makeappx.exe" pack /d "C:\Delphi\WA15\WinArhi\!Executabil Showroom\UWP\Root" /p "C:\Delphi\WA15\WinArhi\!Executabil Showroom\!FINAL\WinArhi_15_Showroom.msix"
Microsoft (R) MakeAppx Tool

Copyright (C) 2013 Microsoft.  All rights reserved.


The path (/p) parameter is: "\\?\C:\Delphi\WA15\WinArhi\!Executabil Showroom\!FINAL\WinArhi_15_Showroom.msix"

The content directory (/d) parameter is: "\\?\C:\Delphi\WA15\WinArhi\!Executabil Showroom\UWP\Root"

Enumerating files from directory "\\?\C:\Delphi\WA15\WinArhi\!Executabil Showroom\UWP\Root"

Packing 30 file(s) in "\\?\C:\Delphi\WA15\WinArhi\!Executabil Showroom\UWP\Root" (content directory) to "\\?\C:\Delphi\WA15\WinArhi\!Executabil Showroom\!FINAL\WinArhi_15_Showroom.msix" (output file name).

Memory limit defaulting to 5368131584 bytes.

Memory limit defaulting to 4294967296 bytes.

Using "\\?\C:\Delphi\WA15\WinArhi\!Executabil Showroom\UWP\Root\AppxManifest.xml" as the manifest for the package.



Package creation succeeded.



Share this post

Link to post

Strange... if I change the 44x44 logo to have more black, it will show transparent in taskbar.

I discovered this accidentally trying do alter the image to be sure it's the right one.

A little black will not suffice. Something more than 1/3.

  • Thanks 1

Share this post

Link to post

We changed the border to be more grey (right image) and it was accepted as transparent (unplated) for MSIX installations.

For non MSIX install the left icon is transparent.



Share this post

Link to post

Hi, as an alternative solution, editing AppxManifest.template.xml line from

<uap:VisualElements BackgroundColor="#464646"


<uap:VisualElements BackgroundColor="#CCE8FF"

worked for my app

#CCE8FF is background color of both 44x44.png and 150x150.png

Not fully transparent, but better than dark gray

Share this post

Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now