Jump to content
Sign in to follow this  

[iOS} SFUI-regular, anybody with font issues in iOS-13 ?

Recommended Posts

Hi all,


after tests with iOS 13 I see changed font appearances, and I hardly could find a device showing this.
On my development devices iPhone X, etc. all at iOS 13.1.2  I didn't noticed that before.
Only a customer point me on this, and I could get one iPad showing this error (also at iOS 13.1.2).


It seems to change the fonts from some non-serif before, to a serif-kind appearance.

When I check the font with IFMXSystemFontService, I got SFUI-Regular, 14pt at result

This pointed me to this link.

So something seems to be changed in the font-system.

I cannot find any reference of SFUI related fonts in Firemonkey, so I assume this is not defined by Delphi.

I've tried to set a custom font service, like this, but I'm not 100% sure if that really works and solves the problem.
Since I have not build a separate tfone test yet, I cannot really check the font appearances in a nice way.


Maybe somebody here has had similar issues, and could point me in the right direction ?


Share this post

Link to post

I don't understand.
I updated to iOS13 and in the SDK-Manager I updated to iOS13 as well.
The XCode version is  11.1,  the iOS SDK version is 13.1, what can go wrong here ?


Do you have a reference, is this a problem from Apple ?

Edited by Rollo62

Share this post

Link to post

I remember that I was able to download older iOS SDK at MemberCenter Downloads Other (some years ago),
but now I cannot see any.

In the web I found some very old notes, that XCode 11 should include at least the last 3 valid SDKs, but I cannot see them in the XCOde package.
Only when I add a project, I could target this to iOS 12.4, and it seems to compile and run nicely, but I don't know where these iOS SDKs maybe hide.

With General\Deployment info\Target I can make such changes.

How can I do so, without iOS 12.4 ?

When searching in the XCode\Contents\Developer\Platforms\iPhoneOS.platform\Developer\SDKs

I only see iOS 13.
What I remember from my earlier expeditions (years ago, since I haven't need to fumble in XCode for a long time now),

that also other IOS SDK's may lay there, but I can find any.


My plan would be to download the older SDK's somewhere, and copy them into above link,
but I cannot really find the SDK file of e.g. iOS 12.4.


One way would be to download XCode 10, to get the right SDK, but isn't there a smaller download available ?


Edited by Rollo62

Share this post

Link to post

I downgraded to SDK ios 12.4, and target device is still Ios 13.12.

Now it shows SFUI-Text instead of -Regular.

Hope that problem, among others, will be fixed soon.

Share this post

Link to post

Thanks for the link, yes thats the same issue I see here.
Not sure what font is chosen, but its unfortunately not even close to the original.

Still I think that Apple changed their system fonts, so its not originally a Delphi issue.
But Delphi has to fix it anyhow.
That probably means that there needs to be a selection if iOS13 or < iOS13 is installed, to either fix it or keep as is.
For me its important to keep the same look and feel on all versions.


I've already tried to use the custom font service, I will try again to fix it with SFUI-Text next week, hopefully that is still available on iOS13.

What I don't really understand is why this works on some iOS13 devices, and on some other devices it doesn't.
Has iOS some secret differences between different Phones ?
I would expect such differences in special hardware related stuff, but not with such simple things like system fonts.

Maybe there are some settings in iOS which could correct this.
I have read somewhere that some iOS 13 devices may run in a kind of iOS 12 mode, but I have not found more info about that.

Thanks Apple, you've made my day again (and again and again ...).

Would prefer to focus on Android 64-Bit tests instead.

Share this post

Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this