Jump to content

Uses Clause Manager: EXISTING Identifier not found

Recommended Posts

Posted (edited)

I have a question about the list of Identifiers in the Uses Clause Manager:


A specific identifier named SaveStringToFile is not found in the list of Identifiers although its unit (the unit name is MiTeC_Routines - it's a licensed unit ) is in the Library Path.


Could it be because it's enclosed inside these compiler directives in the interface section of the unit?

procedure SaveBytesToStream(ABytes: TBytes; AStream: TStream);
procedure SaveBytesToFile(ABytes: TBytes; AFilename: string);
procedure SaveStringToFile(AString: string; AFilename: string); overload;
procedure SaveStringToFile(AString: ansistring; AFilename: string); overload;

That's because of other identifiers OUTSIDE these compiler directives from the same unit ARE being found.

Edited by PeterPanettone

Share this post

Link to post

I have tried to clear the parser cache, but the identifier SaveStringToFile could still not be found.

Share this post

Link to post

The parser still has bugs. It could be as simple as that. If you can produce a small excerpt of the unit that produces this behavior I will have a look.

Share this post

Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now