Jump to content

Delphi Rio 10.3.3 reinstall after uninstalling Delphi 10.4 doesn't update filetypes in registry

Recommended Posts

I just uninstalled Delphi 10.4 (trial ended) and reinstalled Delphi 10.3.3 CE, (had to activate again 2/3 because I reinstalled Windows 10 on the same machine "sigh SSD died" I lost the downloaded slip).

Anyway, after reinstalling, windows registry were not updated TO 20.0 FROM 21.0 for each delphi files, I had to mannually update each registry in HKEY_CLASSES_ROOT, because opening those files from File Explorer tried to use 10.4 executable, file associations were kept from latest version.

I had to pick BDS for each filetype from File Explorer (double click).


At the end I'm reinstalling Delphi 10.3.3 once more, now this uninstaller (InstallAware) seems to delete registry entries for file associations, I'm doing it in case other registry entries not related to file associations are still trying to use 10.4's  sadly, this old Installer/Uninstaller is slower than newer.


Reinstalled and an error message shows on first launch.



Definitely I'm having lot of issues with Delphi, I'm sad. I'm starting to believe that I have to switch to another programming language, which I don't want.


OMG, second reinstall, file associations and launching them still not working. 

Maybe I should reinstall Windows 10 (2004 BTW).

As usual, I'm backuping registry entries to reapply incase the license manager fails on IDE crash, which usually happens to me, restoring from registry entries saved me a lot of times, and migration tool was useless in that case, which forced me to reinstall (the nth times)


I ended up with these icons using Open always with option, I can't differentiate them, maybe I will try to find out which icon index to update to on registry.

Thanks for reading.

Edited by vhanla

Share this post

Link to post

Try going to to Options -> IDE - File Associations and doing Deselect All, Select All and Save.  That should restore file associations for version where you have run Options dialog.


In theory file associations will be reset as soon you save Options even without going to File Associations tab.

  • Thanks 1

Share this post

Link to post

For the complete removal of Rad Studio 10.4 the next time you can use this instruction. In this case, following the steps described in it, you can check if there are still any traces of Rad Studio 10.4 left after the standard removal.

Also verify that you have no Rad Studio 21.0 directories in your Environment System Variables "Path"


  • Thanks 1

Share this post

Link to post

Thank you. Is there any way to know why the IDE crashed and closed itself without any warning? A log file or something? It just keeps closing itself for no reason, I start the IDE and after a while it hungs and closes right away, no warnings, nothing, it just closes randomly, no special steps.

Share this post

Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now