Jump to content
Sign in to follow this  
Jacek Laskowski

MMX 15.0.18 - font bug

Recommended Posts

I'm updating the MMX, setting the cursor on the method, press ctrl+E and...

 

vps_2020_06.30_03.thumb.png.57633a34cf52edf71876c206c025121c.png

 

The same thing happens when I try to enter the MMX options (menu MMX -> Properties...)

 

 

I've traced that MMX looks for FontName and FontSize in the registry, in the IDE settings in the Theme subnode, if there are no FontName and FontSize, this is an exception. I don't have these settings.

I've written it down and it works, but... something is wrong.

 

Delphi 10.3

Edited by Jacek Laskowski

Share this post


Link to post

Yes, that has already been reported by others and will be fixed with the next update. Meanwhile adding these entries to the registry is the suggested workaround.

Share this post


Link to post
6 hours ago, Uwe Raabe said:

Version 15.0.20 should fix this issue.

Now is ok, MMX works, thanks!

 

Just a small remark, the labels do not fit in the frame 😉

 

vps_2020_06.30_04.png.81144a6a59bfae2ffe04420b0fc67a71.png

Share this post


Link to post

MMX from several versions already works really well, does not slow down, does not suspend the IDE, works quite smoothly. Thanks!


I have only one more problem with it. Unfortunately I can't find the rule, although I've been looking for a month.
Sometimes, very rarely, after editing a method in a class by ctrl+E and after approving the editing window by enter, MMX flips the header of the edited method from the public section just below the name of the class, as shown in the picture below. This problem is from about 3 versions back.

 

vps_2020_07.01_01.thumb.png.a745c91a0ff948fcd287070ed141f5f1.png

Share this post


Link to post

Strange! Unfortunately without steps to recreate that will be hard to fix.

Share this post


Link to post

I know, but I can't reproduce.
When something like that happens to me, I'm undo the change and repeating the edit, but the second time is okay.

I'm really trying to understand that and... for now I'm too stupid 🙂

Share this post


Link to post
10 minutes ago, Uwe Raabe said:

Strange! Unfortunately without steps to recreate that will be hard to fix.

I don't think it worth your time, but out of thousands of time i double clicked a method to edit or sometime just to look at how beautiful the Edit Method window, once or two i noticed that the visibility been wrongly set to default, but one in thousands chance.

Share this post


Link to post

I use the latest version of MMX and the problem described above still occurs sometimes. Today I noticed an additional symptom. I have two methods in class, located next to each other, the same names, but the first one is generic and inactive (marked as a comment). After editing the second one and approving both were moved to the beginning of the class:

 

image.thumb.png.cba055234977cd9e9bd0577f0fa011e4.png

Share this post


Link to post

Thanks! There are several issues regarding visibility and they are still being investigated. All reproducible steps are valuable.

Share this post


Link to post

Perhaps the line width is important for this problem. I had 140, now I set 80 and for now the situation has not repeated, I will test for some time, although I want 140 eventually.

 

image.png.ca3d0da8ef58d3ff683364caee3428b1.png

Share this post


Link to post
On 7/1/2020 at 11:15 AM, Jacek Laskowski said:

Sometimes, very rarely, after editing a method in a class by ctrl+E and after approving the editing window by enter, MMX flips the header of the edited method from the public section just below the name of the class, as shown in the picture below.

I guess I finally found the cause: When you edit a property inside an interface the available visibility values are limited to default. Now edit a property in a class and the visibility is also default. The reason is that the current visibility is set before the allowed values are set.

 

A fix will be available shortly.

 

On 10/16/2020 at 12:21 PM, Jacek Laskowski said:

I have two methods in class, located next to each other, the same names, but the first one is generic and inactive (marked as a comment). After editing the second one and approving both were moved to the beginning of the class:

Can you check if you have Pick up any style comments as documentation checked in your MMX Documentation settings? That would take the commented method declaration as a comment belonging to the one below. Consequently the comment is moved together with the method declaration.

  • Like 1
  • Thanks 1

Share this post


Link to post
21 hours ago, Uwe Raabe said:

I guess I finally found the cause: When you edit a property inside an interface the available visibility values are limited to default. Now edit a property in a class and the visibility is also default. The reason is that the current visibility is set before the allowed values are set.

 

I don't think I've written anywhere, but with me practically 99% of classes implement the interface, so there is always an interface behind the class and problems with moving methods to the beginning of the class were ALWAYS present in classes implementing the interface.

 

21 hours ago, Uwe Raabe said:

I guess I finally found the cause: When you edit a property inside an interface the available visibility values are limited to default. Now edit a property in a class and the visibility is also default. The reason is that the current visibility is set before the allowed values are set.

 

A fix will be available shortly.

 

Can you check if you have Pick up any style comments as documentation checked in your MMX Documentation settings? That would take the commented method declaration as a comment belonging to the one below. Consequently the comment is moved together with the method declaration. 

Yes:

 

image.thumb.png.a71619c2742d084e59cf0df9d73dfe91.png

 

I am very happy that I will enter 2021 without this frustrating affliction :classic_rolleyes:

 

Happy New Year!

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
×