Jump to content
Juan Martinez

The android app doesn't start at specific devices

Recommended Posts

Hello. 

 

I have a problem with a comercial android app. 

 

The app runs fine in the majority of android devices. But it's fail in two popular model in Spain: Galaxy A10 (With android 9) and Galaxy J7 Prime (Android 8 ) y Galaxy XCover4 SM-G390F (Android 9).  I have no problem with more than 24 samsung tested models

 

I've tested the two first devices in browserstack.com and i have the attached logcat

 

Could someone help me?

 

I don't know where to start

 

Thanks in advance. (and sorry, my English is not good)

log-all.txt

log-onlypackage.txt

Share this post


Link to post
1 hour ago, Juan Martinez said:

I have a problem with a comercial android app. 

..and its name is? It may help in finding what the problem is from the logs. Better still, what is the package identifier? 

 

Is the app on the Google Play, and if so, is it available in all regions?

  • Like 1

Share this post


Link to post

I've tried your app on my Samsung tablet which has Android 9, and the results are the same. It works on my Pixel 3a which has Android 11.

 

Some questions:

 

Was the application created in an earlier version of Delphi? i.e. like Delphi 10.3.x, or earlier?

 

Does the Libraries node under the Android platform in Project Manager look different to this?:

 

image.thumb.png.703ae82cb377ee158446e39eb88f7514.png

 

Are there any Java classes that your app uses that you needed to create (or find) an import for? i.e. one that was not supplied with Delphi? If so, which one(s)?

Edited by Dave Nottage

Share this post


Link to post

Hello Dave, 

 

I've discovered the problem. I upload and 64 bits apk with a reference to a prebuilt 32 bits apk. I had problems with the aab support in the previous version of Delphi and I prefer this way.

The problem was that I referenced an old .so file in the Android64 deployment window.

 

Samsung J3, Samsung A10... are 32 bits. 

 

Problem Solved. I've learned: check carefully the libs and so referenced in deployment. 

 

Dave: THANK YOU VERY MUCH. It's not the first time you try to help me, and you don't know how useful was your workarounds and firebase examples in your blog. Very talented Delphi developer, no doubt

Thanks

  • Like 1

Share this post


Link to post
3 hours ago, Juan Martinez said:

The problem was that I referenced an old .so file in the Android64 deployment window.

Thanks for that information. It might help other developers who make the same error.

3 hours ago, Juan Martinez said:

Dave: THANK YOU VERY MUCH.

You're welcome!

  • Like 1

Share this post


Link to post

Hi Juan, I have the same problem with an app I released to the PlayStore. I have also written a really simply app for testing which has one text object and one button on it. When run in the IDE with debug 64bit it just sits on the splash screen. The phone is a Samsung Xcover4, but I also have the same problem on Samsung A10 devices as well.  

 

I have attached my test project for information. Can you advise how you fixed the issue in more detail as I cannot figure it out. 

 

Thanks, 

 

Neil

Projects.7z

Share this post


Link to post

Hello Neil, (my English is bad. Sorry).

 

I've tested the project in Samsung A10 and ... it's not ok. 

 

Following the steps: 

 

1º) Run the app with 32 bits debug 

2º) Go to   YourProjectFolder\Android\Debug\Project1\library\lib\armeabi-v7a folder and check the libProject1.so exists ( view the create date )

3º) Delphi IDE: Deployment - Select Debug configuration - Android 64 bit platform. 

4º) UNCHECK  ($BDS)\lib\android\debig\armeabi-v7a\

5º) Add the file "libprojec.so" (step2) and set "remote path" to "library\lib\armeabi-v7a\"

 

I've tested in a Samsung A10 and now all it's fine. 

 

 

Share this post


Link to post

Hi Jaun, 

 

Thank you so much for coming back to me so quickly, I tested the above and that done the trick!

 

I also spotted a problem with my release version, long story short, I forgot to tick the “Generate Android App Bundle file (arm + arm64) in the “Compiling” option with the target set to "Android Release 64bit", I ticked this and re-published my app and that sorted the release version. 

 

Thank you again. 

 

Neil

  • Like 1

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×