Jump to content
Ilie Tache

iOS, Error e8000084

Recommended Posts

Hi to all,


- in this "community edition", I'm trying to make a simple "hello world!" APP
- with no success to iOS Device or Simulator
The environment is:
- Win10 X64 (just reinstalled on clean PC&HDD)
- Delphi 10.3 Community Edition - just installed from scratch
- MacBook Pro Late 2013 - MacOS Big Sur (just installed on clean HDD)
- Xcode 12.4 SDK 14.4
- Xcode 11.5 SDK 13.5
- PAServer 20.0 (from Delphi 10.3 Installed Folder)
- Apple iPad 9.7” (2018), 32GB, Wi-Fi, Space Grey (iOS 14.4)
- iOS Simulator with SDK 13.5, and SDK 14.4
And the error when trying to deploy to iOS Device is: 
And on the iOS Simulator with SDK 13.5:
-  it's not starting
-  it's just present on the device as an icon with no functionality
More Info:
- I've fallowed the procedure described on the help
- made the indicated changes, but no luck
- read all the forums, but I'm stuck here
- I really want to make this demo work, in order to continue with other DEVELOPEMENT
I'm waiting for some clues ....
Edited by Daniel
//edit: Adjusted topic title

Share this post

Link to post

Your error (0xE8000084) may be related to a connection that was lost before the task was completed, for example, the connection was disabled, some process necessary for the connection was killed, the USB cable may be in trouble, etc ...

This can be on the MSWindows or mac side.

see if this post helps you (problem with iTunes 😃 Unknown iTunes error 0xe8000084 )




I for example, have a problem when trying to connect my smartphone to my pc with MSWindows. As everyone knows, the USB connection is used to transmit data and power to charge devices connected to it, such as a smartphone.


So, when the smartphone battery is below 50% or close to that, MSWindows goes "crazy", activating and deactivating the USB connection, because, most likely, the smartphone wants to recharge the power, while I, want a connection of data over USB ... then you've seen the endless fight until the smartphone's battery arrives on a charge.


For this (my) specific case, the solution is to create a connection via Wi-Fi to deploy the Android application (in your case, iOS application), so, I get rid of the USB cable and have a connection between the IDE Delphi 10.3.3 and the smartphone to test my Android apps.


See here on the forum a post of mine on how to use ADB.exe (from Android) and a Wi-Fi connection with the MSwindows PC. Perhaps, you can do something similar on your mac, that is, instead of using a USB cable between devices, you can perhaps use a Wi-Fi connection.

Here in my case, MSWindows + Android Smartphone + Wi-Fi connection, everything works without problems, including the Debugger.


Try this tip.



Edited by Guest

Share this post

Link to post
7 hours ago, Ilie Tache said:

- Apple iPad 9.7” (2018), 32GB, Wi-Fi, Space Grey (iOS 14.4)

iOS 14 is supported only with Delphi 10.4

iOS 13 starting with Delphi 10.3.3

Also "iOS Simulator version 11 or later is currently not supported. You can open Xcode > Preferences > Components , to download and install an earlier version of the iOS Simulator. "



Edited by Cristian Peța

Share this post

Link to post



Thanks far all the quick answers.


- I've tried also with iOS 13.7, but no luck. Same error (e8000084)

- I will install macOS Catalina with Xcode 12.4 and Xcode 11.5, maybe it will work

- I've tried to download patch from link: https://cc.embarcadero.com/item/30915 

- my product registration is "Delphi 10.3.3 Community Edition"


- and on the link above it says I can download the specified PATCH, but I can NOT.


- also I have no PATCHES or fixes for my registered product, on the "embarcadero.com" platform:



Is there a way to fix this download issue?

What I'm doing wrong?



Share this post

Link to post

Hi to all,


Thanks a lot for all the answers and guiding. 

I've solved the problem as follows:

- the main problem was the SDK 32bit vs SDK 64bit

- it seams that when I download the SDK for iOS it was only the 32bit version

- I could only see my iPhone (iOS 14.4) in "iOS Device 32-bit"


- and I was trying to deploy the program to my iPhone witch is a 64bit (iOS 14.4)

- I loaded the SDK for 64bit


- and then I could see my iPhone (iOS 14.4) in "iOS Device 64-bit"


- and SUCCESS.... 


Thanks for all the support and sorry for the disturb...


Best regards,

Ilie Tache




Share this post

Link to post

it seems that the "little cable" on brain was "breaked"  :classic_biggrin: :classic_cheerleader:

Share this post

Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now