Jump to content
David Schwartz

VirtualBox - no audio

Recommended Posts

I've been running VirtualBox on my Mac with Win10 and Delphi installed in it to do my Delphi work.


So far, I haven't needed any audio. But I need to do something with audio, and am having trouble with getting it to work.


I can play some videos on, say, YouTube, but a Delphi app that makes sound via TMS WebCore is silent. When I save it to a web server it works.


I installed XAMPP on my Mac host and now I can open the file at localhost and it works. 


But running it inside of VirtualBox --> no sound.


Actually, it works for a bit right after a reboot of the VM, but then it stops after a time -- I haven't determined what blocks it.


It's not a huge problem, but it would be nice to consistently get audio out of the VM when I want it.


Has anybody run into this and know how to solve it?


I did some searching around and found stuff that says to change some driver in VirtualBox. But all I get is immutable combos with no way to change anything the way the articles explain. So I'm not sure what's going on there.

Share this post

Link to post
Posted (edited)

hi @David Schwartz


many reporting a bug on "macOS" and "Linux" O.S. about "No Sound on VM guest"

  • there is report about use "MultiBeast v4.6 (to old OSX Lion)" but working...
  • any way, the VBox is free and its support is not good-thing... but many other commercial softwares is not, too! you know!

try this article: https://www.virtualbox.org/ticket/20171  --> maybe, more a gif by Apple "black-box"








Edited by Guest

Share this post

Link to post

On my system, the drop-downs (comboboxes) in the first set of images are all read-only and have no options. I can't change them. Not sure why.


And yes, I do have the Extension Pack installed.


Share this post

Link to post
Just now, David Schwartz said:

read-only and have no options.

this is case more reported about macOS dont allow the driver-sound to be recognized by VirtualBox!

Share this post

Link to post

Yes, I did find lots of reports and suggestions about this, but nothing that worked for me.


I was hoping someone here might have found a solution.

Thanks, tho.

Share this post

Link to post

no problem!



Share this post

Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now