Jump to content
Sign in to follow this  
Savvas M

Problem with firedac and Russian - Greek letters in android

Recommended Posts

I have a problem with non-English letters (eg Russian - Greek) in an android app when I store them in sqlite db with firedac (in android 10 and 11 they appeared wrong. In version 6 that I tried they appear correctly)

They all appear as ???????

I tried also with Firedac_SQLite demo (in Mobile Snippets folder)  that ships with Rad studio (10.4.1 and 10.4.2) and I have the same behavior (add a task and save it I see it as ??????.. in case that I don't use English letters).  

I tried both 32 and 64 versions of android. 

Does anyone have any idea how I can solve this?

Thanks in advance.

Share this post

Link to post

maybe help you (or not)

-- SQLiteAdmin DB = MyNewDBSQLite3.s3db
-- VCL project test
-- FireDAC components

				procedure TForm1.FormCreate(Sender: TObject);
				  FDConnection1.Connected          := false;
				  FDConnection1.Params.Values['Database']     := 'D:\RADRIOTests\VCL_SQLite_DB_Unicode_Test\MyNewDBSQLite3.s3db';
				  FDConnection1.Params.Values['OpenMode']     := 'CreateUTF16';
				  FDConnection1.Params.Values['StringFormat'] := 'Unicode';
				Memo1.Lines.Add('Field = Text_Any = ' + FDQuery1.FieldDefs.Items[1].FieldClass.ClassName); == Field = Text_Any = TWideStringField				







				FDConnection info:
				Connection definition parameters
				FireDAC info
				Tool = RAD Studio 10.3
				FireDAC = 17.0.0 (Build 93731)
				Platform = Windows 32 bit
				Client info
				Loading driver SQLite ...
				DLL = <sqlite3_x86.obj statically linked>
				Client version = 3.28.0
				Compile options = DEFAULT_CACHE_SIZE=8000;DEFAULT_FILE_FORMAT=4;
				Session info
				Current catalog = 
				Current schema = 
				Total changes = 0
				Database encoding = UTF8
				Encryption mode = <unencrypted>
				Cache size = 10000				



Edited by Guest

Share this post

Link to post

Thank's for your answer but it didn't help in android, in windows that I tried it works fine.

Share this post

Link to post


Maybe this is the same problem as arabic, a font problem and not a database problem.

I don't remember in which post I saw that, but I remember changing some emb. units did the trick for arabic.


changing those 3 files FMX.TextLayout.GPU,

FMX.FontGlyphs and FMX.FontGlyphs.Android.


Edited by Serge_G

Share this post

Link to post

Hi, thank's for the reply,

It must have to do with firedac, I just tried the same example using dbexpress and it works correctly.

Share this post

Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this