Jump to content
David Schwartz

FastMM4 with D10.4.2 -- need $G ???

Recommended Posts

I've used FastMM4 plenty of times, but I don't think I've used it with 10.4.2 at all.

 

I keep getting this error message now:

 

[dcc32 Error] E2201 Need imported data reference ($G) to access 'IsMultiThread' from unit 'FastMM4'

 

I read the info on it, and nothing I tried worked. 

 

i didn't see this with 10.3.x or earlier versions.

 

I've tried both FastMM 4992 and 4993, and get the same results when compiling.

 

Is there a flag in the 10.4.2 IDE I need to set?

 

 

Share this post


Link to post

I have had this while using the Mormot library for years. It is FastMM related and I need to go into the mormot library and uncomment the FastMM stuff.

Only happens when compiling custom packages though, never had it outside of that scenario. 

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×