Jump to content
Joe Sansalone

iOS deployment problem

Recommended Posts

Things were working before.

I think there was an update for Xcode to install command line tools

and also I updated to the latest 11.1 patch which required a re-install of PAServer.

 

The connection to PAServer is fine.

 

Don't know what this error is:

 

[PAClient Error] Error: E6664 xcode-select: error: tool 'actool' requires Xcode, but active developer directory '/Library/Developer/CommandLineTools' is a command line tools instance

 

 

Share this post


Link to post
5 hours ago, Joe Sansalone said:

[PAClient Error] Error: E6664 xcode-select: error: tool 'actool' requires Xcode, but active developer directory '/Library/Developer/CommandLineTools' is a command line tools instance

Something has changed the active developer directory. If your Xcode is in the default install location, use this command:

sudo xcode-select --switch /Applications/Xcode.app/Contents/Developer

To correct it

Share this post


Link to post
Posted (edited)

Ok It runs and does deploy AFTER using your "sudo code-select --switch ..."  But this error shows up:

(Ignore the red line)

 

iOS-Deploy-error.thumb.png.1e7f071a559e03fb68e40851bea1616f.png

Edited by Joe Sansalone

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×