Jump to content
Edwin Yip

Stuck half way through fixing the XE4 help system

Recommended Posts

I need advise on solving the IDE help system not working issue, it's XE4 on Windows 7.

I don't know since when it stopped working, but the error is as following:

RAD Studio's help namespace is not defined. Please reinstall RAD Studio's documentation.
class not registered, ClassID: {314111F0-A502-11D2-BBCA-00C04F8EC294}

So I found the instruction from embt: https://support.embarcadero.com/article/43035

The help installer almost worked until I got the following error:

** Error **
MS Help 2.x runtime files are not installed on this PC.
Installation/registration of Help files cannot proceed.

According to Google and a MS forum post, I need Visual Studio 2008 SDK which still has a download on cnet.com, so I got it.

But the installation cannot proceed since I don't have Visual Studio 2008 installed, so I stuck.


I don't want to re-install the full XE4 because I've got so much IDE plugins and custom settings. Any advise? Thanks.

Share this post

Link to post

See attached, I think I have all the VC 2008, 2010, 2012, 2013 and 2017 redistributables...

vc redistributable list.png

Share this post

Link to post

Thanks for the info, tried both h2reg and h2viewer, both give me the following error:

MS Help 2.x runtime files are not installed on this PC.

I wish Delphi kept using the good old CHM or .hlp help file formats...

  • Like 1

Share this post

Link to post

They've already gone back to them. On the recommendation of MS itself:classic_biggrin:

  • Like 1

Share this post

Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now