Jump to content
Sign in to follow this  

XCode 11.6 (and 11.5) doesn't recognize iPhone XS anymore

Recommended Posts

Hi there,


related to this post, but I think its a very different issue.


As explained, I used XCode 11.5.x and iOS13.5 for quite a while (weeks and months) happily, and

then focused a little more on Android, leaving aside iOS, not connecting to XCode during this time.


Then after maybe 2-3 weeks later, I've got back to my (unchanged) iOS / XCode / OS setup, and
suddenly XCode didn't recognize my phone anymore.


I'm using the following setup, and did the following measures to get back on track, but nothing helped so far.

  • Working in host (Macos 10.15.4), current VmWare Fusion (11.5.6) on a current MacBook with enough power and space
  • I didn't change anything, it was running well before
  • when plug in the phone, the USB selection dialog appears, and I can connect to the VM, as usual
  • VmWare shows that iPhone connected to the VM-image, just as it should and as before
  • VM image can show the USB, when also iPhone entry is visible, just as it should
  • The problem is that XCode doesn't recognize the iPhone at all
    But I can build release packages normally.
  • I've tried rebooting Host, Client VM, iPhone many times
  • I've tried updating all to latest XCode 11.6 and iOS 13.6
  • I've changes the SIM-Card, to be sure there is no strange hardware error.
  • I've un-trusted the iPhone, but still XCode doesn't react at all


This seems not to be an easy one this time, and I'm not sure if this is related to iOS13.6 at all, because this did stop working at iOS13.5 already.

Maybe somebody has a clue what could go wrong here ?



Share this post

Link to post

Yes, there are NO devices.

Exactly that is the problem.


It seems that the phone in the OS is not really distributed to XCode anymore, while I can see that at VM scope and in the Macos guest scope system info.


I used an USB2.0 hub to connect it to the USB3.0 ports of the host,

that worked well for years, maybe something has changed now.

In the VM I have set USB2.0 compatibility.

I'm going to check today if it makes a difference if I connect it to the USB3.0 port directy.




When I connect the phone to the host Macos XCode (an older version), then the same phone on the same USB2.0 hub

is detected and listed in the Devices & Simulators, as usual.



When I try with an older iPhone 6, also this connects well to the VM, but is not visible for XCode.







Edited by Rollo62

Share this post

Link to post

Oh, yes.

It seems to be another certificate issue:


In the Certificates/Devices section I've got this message


Before adding new devices, make sure your device list is updated for the new membership year. You have the option to remove devices from your list.


Then had to confirm:


Now that you've started a new membership year, make sure your device list is up to date. Once you complete this process, new devices can be added.

Select the devices you'd like to keep for this membership year and deselect the devices you'd like to remove. Only your currently enabled devices are shown and all previously disabled devices will be removed automatically. To keep a previously disabled device, visit the All Devices page, enable the devices you'd like to keep, and return to this page.

Confirm again:


Confirm your devices and reset

and again ...


Review and confirm the devices you have selected.

You currently have the following number of devices available for registration. This count will update once you complete the reset process.


I acknowledge that any devices I disable during this membership year will continue to count towards my total registered devices.


until you've made yourself really clear that you want to move on development, and not suddenly want to stop it.


What is that good for,  another level of bu**hit to punish us developers, I never noticed that before ?

Maybe this came from the complete change of AppleConnect last year.


Anyway, that bad news is that afterwards XCode STILL did not see my devices, although I restartet it already.

But I have a reasonable clue now, and try to peek here and there further ...


Why dont they give a clear message in XCode then, as Apple knows very well whats going on.




Edited by Rollo62

Share this post

Link to post

I have to give up for the moment, this already costs too much time.
The certificates are OK, and I've tried to repair, revoke, renew them several times.


The result stays the same:

I cannot see my devices in VmWare Fusion - XCode anymore,         but on real hardware - XCode it works as usual.


For the moment I have to work on hardware Macos again, until I find more time to look into this.


This is not an Delphi issue at all, since I'm not even able to do anything in XCode.



Share this post

Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this