Jump to content
rudy999

10.4.2 issue maybe

Recommended Posts

in one of my applications there is a custom menu component -not TMenu

i have been using it pre 10.4.2

in one application App A I am working on (so far), when I open up the project I get the message 'xx' component not found.

--However it is installed (and in the pallette).

If I open another application (not with this component) and add the menu vcl to this app and close this app and open up the first

app then it appears again - no error message.

HOWEVER when i close Delphi and re-open it and open App A - same error message until I run the excercise described above.

I have not seen this before.

(I have not yet checked other apps using this component since I just updated to 10.4.2)

 

Any suggestions welcome.

stay safe

 

 

 

Share this post


Link to post
Guest

if not fouded, then, is not good installed in your IDE

  • verify the BPL/DCP if is in the path of your IDE
  • prefere install your components with "output" of BPL/DCP files to "PUBLIC\...\Embarcadero\nnn\BPL and DCP folders" - the IDE will go found it!
  • the DCU, can be any folder where you have access! Norlmally, in same root of the *.pas files \<<platform = Win32, Win64, etc...>>\<<compilation mode = Debug or Release>>\*.dcu - this will be the path on IDE "PATHS" definition to Debug, for example
  • if any exception on use or when close your app/project, verify if you component it's destroyed when end the task or if the "application" destroy it!

the rest, is so much enigmatic question and info!

 

hug

Share this post


Link to post

If I open up RAD studio and the problematic applicaiton is the first one I open I have this issue.

The VCL component is installed and the BPL exists in the correct location.

"Class xxx not found" Ignore the error and continue etc. message.

-If I close the project (without saving) - open another project with the same VCL component without error - close this project

the problematic projects opens - WITHOUT this error.

 

-If I open RAD Studio - FIRST open another project with the component -no errors - I close this project and open up

the problematic project - NO ERROR.

 

It may not be a general issue with 10.4.2 but there is some error - corruption with the project. This same project was being developed in 10.4.1 for weeks with no issue.

Hope this helps.

Any ideas - comments - suggestions will be looked into.

 

 

Share this post


Link to post

Does contain a frame or form with visual inheritance? 

Share this post


Link to post

Lars

 

Do you have a possible idea on this one?  There are no TFrames(s).

The main form has a TPagecontrol on the TForm.

 

I am using this code:

procedure DockForm(Source: TControl; Destination: TWinControl);
begin
     if Source = nil then
          Exit;
     if Destination <> nil then
     begin
          Source.ManualDock(Destination, Destination, alClient);
          Source.Align := alClient;
          Source.Show;
     end
     else
     begin
          Source.Visible := false;
          Source.ManualDock(nil);
     end;
end;

**This is from  DOPC code - KASSL since this is an OPC client project -I implemented this from an example project from KASSL.

This places some other forms visually in elements of the main form, but that code is ONLY executed at runtime, right? In other projects I make extensive use of TFrames, but not this one.

**Again - this issue is new.

Regards

Share this post


Link to post
Posted (edited)

I had similar phenomenon after reinstalling 10.2, though only for a moment then it went away.

The freshly installed component wasn't loaded.

The IDE decided to treat it as a "dynamic package" and loaded/unloaded it depending on the project.

 

Edited by Attila Kovacs

Share this post


Link to post
17 hours ago, rudy999 said:

I get the message 'xx' component not found

Can you please provide the exact class name? It's not the class of your menu component, but the class of menu item, right?

Share this post


Link to post

Balabuev

-It is the class of the menu component - not a menu item. See attached.

As per earlier posts - I can always 'get it back' - temporarily and so far it only an

issue in the one project.

It is an OLD component I have carried over many Delphi versions.

The only reason I use it is that I can set the FONT of the menu.

I am looking at alternatives also

thanks

TBCBarMainMenuIssue.png

Share this post


Link to post

Side note=I went back to TMENU and used screen font to set font size as desired.

 

Otherwise issue still exists

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×