Jump to content

TWSocket Listening problem

Recommended Posts


I'm using TWSocket with C++Builder  listening on port 80.


WebServer->Addr = "";

WebServer->Port = "80";


Yes I know what you going to say. But.


On my Windows10 64bit machine it works fine. I can enable it and disable it and so with no issues.

And I can connect either locally ( or remotely and I get the connection and the browser receives the data I return.


When I copy my exe upto a cloud server also Windows10 64bit - the socket Listens ( no errors ) but no connections ( locally or remote ) are received and when I close the socket, it doesn't close properly and I get an error if I try reopen the port, saying it's already in use.


Any ideas ?

Share this post

Link to post

Probably a firewall on your cloud server, although it may be IIS is already listening on all IP addresses so traffic goes there instead.  Generally better to listen on specific IP addresses, not all.  If IIS needs to run, you need a registry patch so it only listens on specific IP addresses.  Mind with modern cloud servers, you may only get one IP address. (mine has 30).




  • Like 1

Share this post

Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now