Jump to content
Raymond Ng

Delphi 10.4.2 with XCode13 SDK15.0 packaging ipa fail

Recommended Posts

[PAClient Error] Error: E0776 2021-10-05 03:26:02.902 xcodebuild[628:7154] [MT] IDEDistribution: -[IDEDistributionLogging _createLoggingBundleAtPath:]: Created bundle at path "/var/folders/3h/q_v8b1m557s711_wxzzg5s3w0000gn/T/TestingMyApp_2021-10-05_03-26-02.902.xcdistributionlogs".
[PAClient Error] Error: E0776 2021-10-05 03:26:04.636 xcodebuild[628:7286] CFURLRequestSetHTTPCookieStorageAcceptPolicy_block_invoke: no longer implemented and should not be called
[PAClient Error] Error: E0776 error: exportArchive: The operation couldn’t be completed. (IDEFoundation.DistributionAppRecordError error 3.)
[PAClient Error] Error: E0776 IDEFoundation.DistributionAppRecordError.buildNumberRequestFailed(DVTAppStoreConnect.BuildsService.Error.responseErrors(ResponseErrors (1): Error status: 400, code: PARAMETER_ERROR.INVALID, title: 'A parameter has an invalid value', detail: ''' is not a valid filter', id: 3ff08166-1723-4b4c-96d2-ddac6df5fdfc))
[PAClient Error] Error: E0776 ** EXPORT FAILED **
Failed
Elapsed time: 00:01:22.6

 

Any1 can help advice what's wrong?? There is no error for XCode12 with SDK14.4.

Share this post


Link to post
1 hour ago, Raymond Ng said:

Any1 can help advice what's wrong??

Known issue, caused by changes in Xcode 13. At present, reverting to Xcode 12.x is a solution

Share this post


Link to post

Thanks for your comment !

 

Any workaround option available ? As my App is crash in iPhone 13.

 

Is there any Xcode 12.x version that can support iPhone 13 with iOS15 ? 

 

Is Delphi 11 support Xcode 13 ?

Share this post


Link to post
3 hours ago, Raymond Ng said:

Any workaround option available ?

I may have one in the next day or so.

3 hours ago, Raymond Ng said:

As my App is crash in iPhone 13.

That is likely to be a completely different issue. Does it happen on other iPhone models? Can you provide code that reproduces the problem? I have access to an iPhone 13 that I can test on.

3 hours ago, Raymond Ng said:

Is there any Xcode 12.x version that can support iPhone 13 with iOS15 ? 

iOS 15.0 SDK comes with Xcode 13 (not earlier versions). I'm not sure if you can switch back to Xcode 12.5.1 and still build against iOS 15.0 SDK

3 hours ago, Raymond Ng said:

Is Delphi 11 support Xcode 13 ?

The issue we've been discussing affects Delphi 11 and earlier. 

  • Like 1

Share this post


Link to post
21 hours ago, Dave Nottage said:

I may have one in the next day or so.

I have a workaround now which is implemented in the Codex and Mosco tools (or just using Mosco if you're OK with using the Mac to perform the fix)

 

The tools with the workaround are presently in beta, and can be accessed via my Slack workspace which you can self-invite to here. (if not joined already). Go to the #codex channel and there is a pinned post with the installers for Codex and Mosco

Share this post


Link to post

Eu também tenho esse problema com rad studio 10.4.2 ,  consegue me enviar o link para ter acesso as correções?

Share this post


Link to post
14 minutes ago, Alisson said:

Eu também tenho esse problema com rad studio 10.4.2 ,  consegue me enviar o link para ter acesso as correções?

Links to Installers for Codex 1.5.1 and Mosco 1.2.1. Includes workaround for App Store builds with Xcode 13. Requires at least Mosco to be installed, however the Codex tool adds a convenient way of applying the workaround. Workaround steps:

  • Build/Deploy your app using App Store config (which will "fail" with Xcode 13)
  • If using the workaround in Delphi itself, in Project Manager, right click the root node of the project and click "Build IPA"
  • If using the workaround in Mosco, click the Mosco icon in the system bar to bring up the menu, click Fixes > Build App Store IPA. Select the app from the ~/PAServer/scratch-dir/[username]-[profile]/ folder and click Build

https://github.com/DelphiWorlds/Codex/blob/master/Bin/CodexSetup_1.5.1.exe
https://github.com/DelphiWorlds/Mosco/blob/master/Bin/Mosco.1.2.1.pkg

Use o Google Translate se quiser as instruções em português: https://translate.google.com

Share this post


Link to post

Eu instalei codex no windows onde roda o rad studio e o mosco no Mac. Após isso cliquei com o botão direito do mouse no nó raiz do projeto e clique em "Build IPA", mas retorna a seguinte mensagem: ''Could not conect to Mosco''. Existe alguma configuração necessária no mosco?

 

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×