Jump to content

Disable the Jedi property editors?

Recommended Posts


when I edit the property of TForm.Caption... in the Object Inspector:


...then this dialog appears:



I assume that this is the JEDI StringList property Editor (because of the "J" icon)?


Is there an easy way to disable just the Jedi property editors?


BTW: A property editors Manager for Object Inspector would be very nice!

Edited by PeterPanettone

Share this post

Link to post

You have to modify the design-time package that registers the property editor and rebuild it. Or just disable the package if you do not use any of the controls from it.

Share this post

Link to post

The JVCL Installer has a checkbox to turn the Global Designtime Editors off. It controls the registry key


RegisterGlobalDesignEditors: DWORD = 1
Edited by jbg

Share this post

Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now