Jump to content
Sign in to follow this  
Stéphane Wierzbicki

RIO - FDMemTable fielddefs design time bug ?

Recommended Posts

Hello,

 

Can any one test this ?

 

Create a new VCL application

Drop a FDMemtable

Edit FieldDefs property and :

 - create 2 fields

 - Select any of the created field and change it's datatype : the datatype dropdown list will display datatypes twice

 - create 2 other fields

 - Select any of the created field and change it's datatype : the datatype dropdown list will display datatypes 4 times

 

 

Thank you

Share this post


Link to post

Cannot reproduce. Datatype dropdown list contains unique values here.

Share this post


Link to post
21 minutes ago, Uwe Raabe said:

Cannot reproduce. Datatype dropdown list contains unique values here.

I missed a step :

 

Create a new VCL application

Drop a FDMemtable

Edit the FieldDefs, dialog will appears:

 - create 2 fields

 - Select any of the created field and change it's datatype : the datatype dropdown list will display all datatypes

Close FieldDefs dialog

Edit again the FieldDefs dialog will appears:

 - Select any of the created field and change it's datatype : the datatype dropdown list will display duplicated datatypes (2 times)

 - create 2 fields

 - Select any of the created field and change it's datatype : the datatype dropdown list will display duplicated datatypes (4 times)

Share this post


Link to post

It is not only FDMemTable or FieldDefs, I see it regularly.

 

If you select it a second time you have the unique values again.

Share this post


Link to post
35 minutes ago, pietrt said:

It is not only FDMemTable or FieldDefs, I see it regularly.

 

If you select it a second time you have the unique values again.

It's the first time that I've noticed this.

Do you see this on RIO especially ?

Share this post


Link to post
1 hour ago, Stéphane Wierzbicki said:

Bizarre... maybe an IDEFixpack side effect

Yes .and on many other properties (FMX)

Share this post


Link to post
1 hour ago, Stéphane Wierzbicki said:

maybe an IDEFixpack side effect

Indeed! I can reproduce it with IDEFixPack installed.

Share this post


Link to post

There is a new IDEFixPack development snapshot that fixes the issue. The TCustomListBox.ResetContent patch didn't clear the "FSaveItems: TStrings" list if no handle was allocated.

Share this post


Link to post
5 hours ago, Stéphane Wierzbicki said:

Thank you Andy. 

Is this the same download link? 

That's a link to the post in the other thread where the download link is.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×