Jump to content

MSBuild error when switching platforms and try to compile

Recommended Posts

With Delphi 11.1 update 1 and firemonkey platform, with targets Win and macOS, when I compile for Win, no issue, then I switch platform and try to compile for osx, and get the following error:



[MSBuild Error] The "BRCC32" task failed unexpectedly.
System.IO.IOException: The system cannot find message text for message number 0x%1 in the message file for %2.
at System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath)
at System.IO.File.InternalCopy(String sourceFileName, String destFileName, Boolean overwrite, Boolean checkHost)
at System.IO.File.Copy(String sourceFileName, String destFileName, Boolean overwrite)
at Borland.Build.Tasks.Common.CommandLineTask.CreateTempFileIfNecessary(ITaskItem basedOn)
at Borland.Build.Tasks.Common.CommandLineTask.Execute()
at Microsoft.Build.BuildEngine.TaskEngine.ExecuteInstantiatedTask(EngineProxy engineProxy, ItemBucket bucket, TaskExecutionMode howToExecuteTask, ITask task, Boolean& taskResult)


When I exit and restart the ide, I can compile for osx, but the same error comes up when switching back to Win64 target.

Share this post

Link to post

I get the same error when I change anything in the project options. Even setting the icon gives this error.

Share this post

Link to post

I have this error many times but I think I found the reason

If I have an open project in the IDE and I update through git a library source from Github that it is used by this open project I reproduce this error

After that error I can go to Tools->Options->Editor, click save to any subtab and then write a space somewhere in the source

Either compile, or build, clear this error without requesting to restart the IDE

Share this post

Link to post

BRCC32 is to resource compiling, then, can some resource (*.res, *.ico, etc..) be corrupted or read-only when trying recreate it?

if you are using a "git/svn/mercury/etc..." this file can be in use in moment of compilation, by other process, or some like this! then the "res" files cannot be created!

Share this post

Link to post

I have this same problem in C++ Builder. No idea what might be causing it. Restarting the IDE seems to solve it.

Share this post

Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now