Jump to content
Piotr0603

Deployment Android apk

Recommended Posts

Hi, I am new in Delphi (10.4 Community Edition) developing on Android devices. I want to add a little text file to my apk on Android device. I do all what is described  in https://docwiki.embarcadero.com/RADStudio/Alexandria/en/Deployment_Manager:  (Alexandria or 10.4 - the diffirence does not matter I think)

1. choose file in my laptop (Windows 10) - file is shown in Deployment Manager with the same name

2. in column "remote path"  write the name of directory on Android device: .\assets\internal\Android\data\com.android.Tuczarnia\files\  (Tuczarnia is the name of apk)

3. build the apk 

4. my file can't be found on folder ..internal\Android\data\com.android.Tuczarnia\files\ 

 

5. I noticed that 'Connect" button in Deployment Manager is not active and all files have status "Not Connected", but it seems (after reading help of Deployment Manager) that this works automatically for Android

6. and I noticed, after unzipping the "apk" file, that my file is present in "assets/internal/Android/data/com.android.Tuczarnia/files/" inside that file

7. so it seems to me, that file is lost during the process of installing the apk  -  WHY?

 

I use and have

1. Windows 10

2. Delphi 10.4 Community Edition

3. phone Xiaomi Redmi 8 with Android 10

 

Important: my application works fine without adding this file, application has over 10 screens and uses SQLite with no problems. So only one and new problem is adding new file.

 

Thanks in advance to everyone

piotr0603

 

Share this post


Link to post

Basic rule:
put your code here. Otherwise they can't help you.

Share this post


Link to post

There is no code. There are only settings in Deployment Manager.

I want include file while installing application on Android device, not at runtime, just "within" the process of installing it.

deployment manager.bmp

Edited by Piotr0603
including screenshot

Share this post


Link to post
14 hours ago, Piotr0603 said:

I did read and have no idea what I did wrong

Did you notice the target shown as assets\internal in the help section linked? Try it with just what the help suggests to start with. Usually prefer .\ vs an empty directory string as well. 

Edited by Brian Evans

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×