Jump to content

Removal of startup Plug-In in Delphi Rio

Recommended Posts


I have a plug-in (Konopka VCL) that shows it is being loaded at startup of Delphi (10.3.3), but which isn't working correctly. The GetIt package Manager doesn't show that this plug-in is installed so doesn't have an 'uninstall' option. It does have the 'install' option, but when I try this it fails when trying to copy files which are held by another process (presumably Delphi since it 'loaded' the plug-in at start - see attached screenshot).


So for some reason it's got itself in a catch 22 state! I can neither use the plug-in nor uninstall it nor re-install it. I imagine I can uninstall the whole of Delhi and start again, but I'm wondering if there is a way to tell Delphi NOT to load that plug-in? If I can do that then maybe GetIt will install the plug-in without an error.


Another option would be to run GetIT outside of Delphi, then it might work because Delphi would not be holding on to any files that would stop the copy process.


Any thoughts would be useful.

KonopkaError Install.jpg

Share this post

Link to post

Hi Vandrovnik,

After your post I wondered about the next error, assuming it was caused by my renaming the file. However, it wasn't (I took snapshots), it was for another file in a different plug-in. So I went back and tried the same again (renaming the file). And this time the install worked OK!


So your answer was correct and it was my 'assumptions' that stopped me figuring this out first time. Many thanks for spurring me on.

Share this post

Link to post

Have you just updated from a previous version and "Kept" you registry settings?

I've just done this on Sunday with the Web Installer and has a similar issue as the Web Installer uninstalled any packages it has downloaded (Navigator, Bookmarks, etc.).

I had to use a clean registry (BDS.exe -rClean) to get GetIT to re-install the missing plug-ins / components.

Share this post

Link to post

Hi David,


That's interesting, I'll make a note of this when they go to 10.4. I'm always having issues with upgrading. I don't mind a complete uninstall/reinstall if the upgrade is a major one with most of the files having been changed, but a 10.3.2 to 10.3.3 seems a very minor one. Why they can't just do a replace of the files updated (like most other software vendors do) I don't know. Smacks of laziness to me.

Share this post

Link to post

Well, I have made a check list for myself which I use for upgrading. Improvements are welcome 🙂


Before upgrade:

- close project, close IDE

- remove IdeFixPack

- backup settings using Migration Tool



- run web install (because I am using it since XE6)

- setup invokes uninstallation of previous version; during uninstall, keep registry settings

- try to run IDE; usually there are missing .bpl files; when it asks whether to try to load them next time, answer yes on all such questions

- close IDE


After installation:

- install TMS

- install FastReport

- install SecureBridge


Run IDE and use Getit to install (usually needs a few restarts):



- Bookmark

- Navigator

- PngComponents

- SynEdit

- VirtualTree


Other components, some of them unsupported:

- prepare for new versions, with major upgrade it usually means copy project files and other corresponding files from names like DsgnCPortD250.dproj to DsgnCPortD260.dproj; edit them, change 250 to 260 inside. Find IFDEFs like IFDEF VER310 and add IFDEF VER320 etc. Often such IFDEFs are in .inc files. When something goes wrong with their compilation, I can be sure that I have not found all places to edit 🙂

- run .bat file, which compiles these components for Win32 and Win64 and makes a list of created .bpl files

- Component, Install packages, Add (I copy/paste paths to design time .bpl files created in previous step)


Reduce annoyance 🙂

- In C:\Program Files (x86)\Embarcadero\Studio\20.0\bin, rename or delete:

  dclbindcomp260.bpl,   dclbindcompfmx260.bpl,   dclbindcompvcl260.bpl,   dclbindcompfiredac260.bpl,   dclbindcompdbx260.bpl

- using Regedit.exe, in HKEY_CURRENT_USER\Software\Embarcadero\BDS\20.0\Known IDE Packages

  set $(BDS)\Bin\startpageide260.bpl = _Start Page IDE Package

  (add underscore, so start page is ignored)


Final steps:

- in some project, I use Vcl.Consts.pas and System.SysConst.pas translated to Czech; it is wise after upgrade to use diff and be sure, that all strings defined in original files exist in my files and also remove strings that were removed from originals

- Tools, Options, Language, Delphi, Library - check library paths for Win32 and Win64, remove obsolete items and add items that disappeared during upgrade


Hope it helps a little.



  • Thanks 1

Share this post

Link to post



Please add:



Windows Registry Editor Version 5.00


After setting this value Delphi will encode new units in UTF-8 with BOM."

Edited by Jacek Laskowski

Share this post

Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now