Jump to content
Sign in to follow this  

Apple Transporter failing to upload IPA with error: Failed to create .itmsp for 'appname

Recommended Posts

Hi there,


this is another chapter of my daily issues with Apple:

Suddenly the update of IPA to AppStore of an formerly running app failed, when using the Transporter.


I usually keep my Transporter open for days and weeks, maybe that causes sometimes an issue.

From my research for this error I found a few possible reasons and solutions in the web, where I've tried to re-boot my VM first.


1. Just relaunch Transporter app, or quit and re-enter it again.  (not tested, but sound reasonable).
2. Try completely shutting down your device and then turning it back on and trying.  (I've tried this one).
3. Check the matching case of the SKU for new apps:
    E.g. "com.company.appName" wasn't accepted.   If changed to "com.Company.AppName", matching the AppStore entry, it works.


Sometimes solutions can be so easy, but I hardly see the easy one's very often 😥


Edited by Rollo62
  • Like 1

Share this post

Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this