Jump to content
Mr. E

Can't reinstall package when previous was installed, new installed, then old removed

Recommended Posts

Regards, this problems occurs from time to time in getit now I got bitten again.

Hopefully someone knows how and where I can tell to Getit that EurekaLog isn't installed so I can reinstall it.


This is the little story:

I got the EurekaLog Tools (free) v 7.0 installed, today I see the new version and I do this:

  • EurekaLog Tools 7 was installed via Getit
  • Without uninstall the v7 in getit: I install the v7.7.5.0; the process goes without error, and the install remove the previous one, the IDE restarts; (I was expecting that Getit remove the old one and take out from Getit but no).
  • In Getit now I see two versions installed. (annoying), then
  • In Getit I uninstall the v7, it removes in GetIt and from Programs and Features too. Now I don't have the programs installed (but Getit shows as installed).
  • In Getit that shows is installed, when I try to uninstall, I got this error, and I can't reinstall again:




This happens with other package, but I don't remember how I "remove it", still get it shows the old version to install, as a reminder that I don't remember :classic_blink:



Thanks in advance.

Edited by Mr. E

Share this post

Link to post

Indeed in my case, the solution is: backup and delete from the registry the guilty one, In my case my version is "..\BDS\18.0\.."


Luis Navarro from Embacadero just explained to me:

Close the IDE, then delete the OmniThread folder from MyDocuments\Embarcadero\Studio\17.0\CatalogRepository After that, you have to edit the registry and delete also the Omnithread folder from HKEY_CURRENT_USER\SOFTWARE\Embarcadero\BDS\17.0\CatalogRepository\Elements

This worked like a charm.
Note that for me there was no registry key in the above path for OmniThread yet. Perhaps the key only gets written upon successful installation of the package.
In that case you only need to delete the PackageName directory and reinstall.


Thank you @FredS

Share this post

Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now