Jump to content
PhilPlus

Planning for V4 (FMX support)

Recommended Posts

Hello

Is there any planning for the V4 version ? 

(sorry if yet answered).

Phil

Share this post


Link to post

I'm only using Delphi tools for threading and synchronization so the end result should work on all supported platforms. I only tested on Ubuntu running on WSL2 though.

Share this post


Link to post

OK but on GitHub I see : 

 

Is OmniThreadLibrary supported on my platform?
At the moment, OTL supports Delphi 2007,...10.3 Rio, and 10.4 Sydney on Win32 and Win64 platforms using the VCL framework.

So I thought OTL depended on VCL.

Share this post


Link to post

@Primož Gabrijelčič

Please clarify what platforms VCL/FMX can be used.
I'm interested in iOS / Android mainly, bit Win32/64 / Macos too.

 

Did I miss that your library is compatible with those ?

Share this post


Link to post
Posted (edited)

I think you mean RTL but only certain platforms (Windows in V3) because I don't see any *visual* components in OTL (OmniThreadLibraryRuntime.dpk also only requires rtl.bpl).

Because technically you can build a Windows-only application using FMX with OTL just fine.

Edited by Stefan Glienke

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×