Jump to content
edwinyzh

Shortcuts in Grep Results window no longer work?

Recommended Posts

I've been using the GExperts trunk from https://svn.code.sf.net/p/gexperts/code) for quite a long time, and I don't remember since when, the keyboard shortcuts in the Grep Results window no longer works.

I most use the F5 (refresh), Ctrl+N (collapse all) and Ctrl + E (expand all)

 

Edit 1: It's under XE4.

Edited by edwinyzh

Share this post


Link to post

I'm not aware of a change that could cause this. Please file a bug report.

Share this post


Link to post

Just checked D10.2.3  V1.3.11.64 experimntal  It works OK

 F5 (refresh), Ctrl+N (collapse all) and Ctrl + E (expand all)

All work
Edited by limelect

Share this post


Link to post

Hm, that was the switch from a main menu to the "hamburger" menu. I guess that's what causes the problem. I made that change for two reasons:

 

1. There was a draw problem with the main menu in the latest Delphi version if theming was enabled (which is now the default so the problem would have been there in whatever configuration.

2. The Grep main menu was sometimes stealing the Alt+F etc. shortcuts from the IDE main menu.

 

Now, the Action hotkeys apparently only work if the Grep result window is not docked.

(Edit: Now it doesn't even work if it is docked. No idea what changed, definitely not the code.)

 

The edit window seems to take all the hotkeys.

Share this post


Link to post

I tried to add yet another expert that uses F5, but unfortunately that disables the F5 key for setting / removing breakpoints, so it's not an option, unless it is turned off and on dynamically whenever the Grep Results window gets the focus. Not my preferred solution.

Share this post


Link to post

I had the issue before the main menu's switched  to the "hamburger" menu.

Even Grep Results window's not docked, the shortcuts don't work.

In the past, once I mouse-click on the window so that it has the focus, all the shortcuts worked.

I'm really not sure if the issue's coming from GExperts itself or the other IDE experts, I use all the major experts and I didn't add new experts to the IDE recently, but I keep updating GExperts, CN Pack and Andy's experts.

Share this post


Link to post

The shortcuts were always supposed to work only when the results window had the focus (some of them conflict with editor shortcuts). Since the switch to the "hamburger" menu, the actions no longer get called.

Also, the form's OnKeyXxx events don't get called when the form is docked (key preview is true), so it's not possible to re-route the shortcuts this way.

The only way I found was to add global actions, but these would block the editor shortcuts (e.g. F5 to set and delete a breakpoint). So that's not a solution either.

In out of ideas for now.

Edited by dummzeuch

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×