Jump to content
Ian Branch

Issue with IDE Nav Bar..

Recommended Posts

Hi Team,

D10.3.1.

It is a long time since I had a 'clean' Delphi edit window.

My PC did a Windows update, 1809, and all hell broke loose.  Had to reinstall Delphi from scratch. 😞

Anyway I install all the usual add-ons, Gexperts, cnPack, DDevExtensions, etc.  Added all the required 3rd party stuff.  All good.

I was busy editing away when I noticed that the IDE Navigation Bar would only show those Functions/Procedures I had added to the app source, none of the ones for normal events.  See attached screen shot 2.

cnPack was displaying all of them.  See screen shot 3.

Is this something wrong or normal?

If the Delphi Nav Bar should be showing all of them, is there a 'switch' somewhere?

I did disable/enable the Nav Bar to no effect.

It only seems to affect those projects that were originally created in D10.2.3 or earlier.  Anything created in 10.3.0 or later is fine.

Thoughts/suggestions?

Regards & TIA,

Ian

Screenshot_2.png

Screenshot_3.png

Share this post


Link to post
Posted (edited)

So, the thicken plots....

I found that most of the source files in the project were in fact ok and all the procedures/functions/events were showing.

Hmmm, what was different in the two that they weren't?

Only two functions were showing.

In my GenKey function, the second in the source, I had the following line..

{code}

  for var i: Integer := 1 to 7 do

...

...

{code}

With the attendant underlining of 'var' and ':='.  See screen shot 4 attached.

Hmmmmm.  I wonder????

So I declared i and changed the code to the conventional "for i := 1 to 7 do"

BINGO!!!  I now get all the procedures/functions/events showing.  See screen shot 5 attached.

Reverse the change and the issue returns.  Reverse it again and all good.

I think I found a Bug!!!

Can someone replicate this and verify please...

I'm going to have a look at the other file now.

Regards,

Ian

 

Update:  Same issue with the same inline code in the second file.

 

Screenshot_4.png

Screenshot_5.png

 

 

 

Edited by Ian Branch

Share this post


Link to post

Hi Attila,

Thank you.  I was aware of the issue with not recognizing the syntax correctly, but I wasn't aware of its impact on the Nav Bar listing of procedures/functions.

Is there a RSP for this?

Regards,

Ian

Share this post


Link to post
9 hours ago, Ian Branch said:

Same issue with the same inline code in the second file

 

You know MMX is free now thanks to Uwe: https://www.mmx-delphi.de/

 

I was going to see if I could duplicate your issue but the Nav Bar thing won't even show all helpers/classes in my file never mind testing that..

 

Share this post


Link to post

Yes, I have MMX installed.

You wouldn't have any in-line variable declarations in your source would you?

Share this post


Link to post
1 hour ago, Ian Branch said:

You wouldn't have any in-line variable declarations in your source would you?

 

No, I was going to add what you posted to test but since I use MMX I hardly use that Nav Bar.

In a large unit it already failed without in-line variables..

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×