Jump to content
Sign in to follow this  
Der schöne Günther

How can I disable IDE talking to external websites?

Recommended Posts

Since about 12 hours ago, my Delphi IDE will spawn about two dozen Internet Explorer "Script Error" dialogs on every launch. I will have to dismiss every single dialog before I can continue.



I can't understand why the IDE would have to use a full web browser to talk to domains I don't even know, but I'd like to disable it and get back to work. Is there a package I can disable for this "integration"?


My only workaround is disabling internet access for the VM Delphi is running on, waiting for the IDE to launch and then turn it back on.

Share this post

Link to post

My guess would be that it is the welcome page that does this, so you could try to customise it removing all the stuff that gets content from the internet.

Share this post

Link to post
9 hours ago, Der schöne Günther said:

I have disabled the "Embarcadero Community" toolbar in the IDE and the issue seems to be gone now 🤞

Fantastic, yeah that works so far for me

Share this post

Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this