Jump to content
Sign in to follow this  
microtronx

Installed 10.4 Patch (Patch Tool) Test 1.0 - Components needing Teechart don't work any more

Recommended Posts

image.thumb.png.8e31746dfcebbaff4c1c68852324d320.png

 

Be sure to have a backup, after installing this patch Reportbuilder and DevExpress Components connected with Teechart are not working any more:

 

image.thumb.png.8a00a4da785a46833987053220c752c8.png

 

So, whats next if we don't have a backup ??

  • Thanks 2

Share this post


Link to post
Posted (edited)

Uninstalling that patch leaves a damaged system! it seems that the patch has uninstalled a lot of components / addons. Now i try to go through Tools menu to install languages, teechart and Androidsdk again ... lets see what happens ...

Edited by microtronx

Share this post


Link to post

Thanks for the heads up. Did you report it at QP?

Share this post


Link to post

Ok, after reinstalling missing components over Tools + Platform manager = everything working again 😉

Share this post


Link to post
Posted (edited)

Thanks for pointing my head to the Patch tool.

Is this an official patch, or not, why this crazy name ?

 

What I don't really understand is what this has to do with TeeChart.

I have currently similar issues, linking to TChart is broken.

 

Is this Patch Tool of any use, or is this just an internal test of Embarcarero before launching the real Patch-2 ?

Is there any available Readme BEFORE installation ?

Edited by Rollo62

Share this post


Link to post
Posted (edited)
14 minutes ago, Rollo62 said:

Thanks for pointing my head to the Patch tool.

Is this an official patch, or not, why this crazy name ?

 

What I don't really understand is what this has to do with TeeChart.

I have currently similar issues, linking to TChart is broken.

 

Is this Patch Tool of any use, or is this just an internal test of Embarcarero before launching the real Patch-2 ?

Is there any available Readme BEFORE installation ?

 I think the Patch has uninstalled all components (Teechart Standard is one of them) which i had selected in time of installation ... right after the patch installed i saw all optional software & languages not installed any more in platform manager.

After reinstalling them with platform manager (tools menu), everything fine again ...

Edited by microtronx

Share this post


Link to post
Posted (edited)

Just for information, this is the readme file of that patch. I cannot see anything related to Teechart or the ability to load packages, but that may as well be hidden somehow.

Also does the patch not include any binary that could be executed or loaded and do any harm.

 

Note, that the patch do save the original files in %BDSCatalogRepository%\Backup.

 

Patch1.txt

 

Update: I just noticed that the mentioned patch is different to the one I was talking about. Will investigate further...

Edited by Uwe Raabe
  • Thanks 1

Share this post


Link to post

Thanks Uwe.

I also will follow the good advice to backup the system, especially because the name of the "patch" doesn't sound too reliable to me.

 

 

 

Share this post


Link to post

I can confirm that the patch misses to install the previous selected languages, samples, help and so on. Especially TeeChart Standard is missing after installing the patch.

I suggest to file a bug report.

Share this post


Link to post

Blind guess: Could it be that we using a German RAD Studio is the cause?

Share this post


Link to post
3 minutes ago, Uwe Raabe said:

I can confirm that the patch misses to install the previous selected languages, samples, help and so on. Especially TeeChart Standard is missing after installing the patch.

I suggest to file a bug report.

So howto get TeeChart back ?

Did I understand right that this works with Manage platforms, and uncheck/check the TeeChart checkbox,

to uninstall/reinstall TeeChart ?

 

My point is that I don't want to re-install the whole IDE at the moment, since I'm fighting to get things stable again.

I've deactivated the TChart in my app for testing purposes.

 

 

Share this post


Link to post
12 minutes ago, Uwe Raabe said:

Blind guess: Could it be that we using a German RAD Studio is the cause? 

A colleague of mine lost both TeeChart and IBX Components. We are using the English version of Delphi 10.4

Share this post


Link to post

Are you sure that the actual files are really removed or is it just that the components are simply not registered anymore?

In my case the Manage Platform dialog shows German language unchecked while the IDE is still running in perfect German.

Share this post


Link to post
50 minutes ago, Bothyhead said:

A colleague of mine lost both TeeChart and IBX Components. We are using the English version of Delphi 10.4

That happened to me. You need to use 'Manage Platforms...' to re-install all the options (TeeChart, IBX, etc.) again.

Share this post


Link to post
Posted (edited)

I've just run the patch, here a list of whats going on:

  1. Before install I had TChart and all Features
    image.thumb.png.99189290057396071091cc7017d03779.png
     
  2. I installed via welcome page
    image.png.4f40a501a49d7336112ebc271b32f00b.png
    this seems to be just a shortcut to the GeitManager
    image.thumb.png.dca3ad72f7d6be9f3396003e5b6b0ad5.png
  3. Got the first message
    image.png.db4070d3a2a3cd46c7ed6978080f4260.png
    Yes, I want ...
  4. Then I've got a fullscreen terminal, which is odd.
    image.png.8a800a531ca28e57b3df5b32e3848d36.png
    because I cannot see a hanging message-box request, it was behind the terminal.
  5. After pressing OK, it moved on
    Seems to de-install all features I've had installed before
    image.thumb.png.ba38598ade6769655dc7f7f5cdcf7556.png
    image.thumb.png.aa72505ccc11cefe56ef05e8f368d36f.png
    even Interbase and all SDK's ...
    image.thumb.png.8099af39cf6dfa40a53ae7a3cbcfe2c1.png
  6. Then its restarting the IDE
    image.png.734200621ad45ddf35433f252dc94658.png
  7. Of course something is missing now, need attention later ...
    image.png.e86760612bbcf511de488a584a1e4be5.png
  8. Then the features components 2nd page were all removed (as they were uninstalled), I had to enable them.
    Even the samples.
    image.png.27dbe58e4c34e3dc807ae5110f949017.png
  9. Installing the components ... tea time ...
    image.png.877181435a90c66146185ac128428d7f.png
    Re-Installing also loads the TeeChart, I hope this is the new version then.
    I will see later in my tests.
  10. Finally after install Teechart is back
    image.thumb.png.aba73eb4486edcd8f7ec5a8b84ad8725.png
    I can compile Android, so also the SDK seems to be back, but I'm unsure if all Android-Components wer initialized.
  11. The welcome page still shows a patch, it seems to be an error in "patch installed" detection
    image.thumb.png.d1db4ec081efe0eadc3b8e7e504b4a71.png
  12. I re-enabled my TChart usage in a project, and compile the project for test.
     

 

I found a few issues then:

1. The message box was hiding behind the full-screen terminal

2. All features were disabled and de-installed, even the samples.
    This is maybe for safety, but I think this could be optimized.
3. When IDE ist startin, to re-install, it noted about missing BPL
    Surely this could be optimized too, to set the IDE into a kind "installer mode" before, ignoring missing BPL.
    Then only show message after 2nd start, if still anything is missing.

4. Patch "installed" detection doesn't work reliably
 

 

 

 

 

 

image.png

image.png

image.png

Edited by Rollo62
  • Thanks 1
  • Haha 1

Share this post


Link to post

Patch (Patch Tool) Test 1.0 is no longer showing in GetIt. What is back, however, are (Parnassus) Navigator and Bookmarks. Available if you have a subscription.

 

  • Thanks 1

Share this post


Link to post
4 hours ago, Mike James said:

That happened to me. You need to use 'Manage Platforms...' to re-install all the options (TeeChart, IBX, etc.) again. 

Thanks, I wasn't aware of that.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×