Jump to content
Leo Lui

My App work perfect in Android but show access violation error!

Recommended Posts

My app pop up "Access violation at address 000000001BB022128, accessing address 000030312E353820" error in iPhone. Android works perfectly without this error.

This error pops up when

1. Run the app

2. Press the home button (my app still running in background)

3. Run other apps 

4. Go back to my app

5. Error popup.


It is quite strange that my development device iPhone 6S never shows this error. All my other testing devices, from iPhone 7 ~ iPhone X, pop this error!

This error exists since XCode 11. I updated it to XCode 12.4 hope that this error can be solved, but no luck!


My development environment is

1. Delphi 10.4.1

2. iOS 13.7

3. XCode 12.4

4. macOS Big Sur

5. My app uses a location sensor component and timer components to activate the location sensor when loading up the App.


(I want to try it in iOS 14.4 but cannot successfully get the iOS 14 SDK add to the SDK manager. Files in Z:\Documents\Embarcadero\Studio\SDKs\iPhoneOS14.4.sdk\usr\lib are in 0 byte. I tried it from XCode 12.0 to 12.3. All failed. I think it should be a bug in Delphi IDE. Only my old iOS 13.7 SDK is still working.)


Does anyone know what causes this access violation error? Please help!







Share this post

Link to post

Looks like an error in activate event, or something like that.


I had someting close to this when moving the device from landscape to portrait, and conversely. It was because of setting text into a label, fired by an event. I has to put the code into a thread.Synchonize...


It was running fine every where, except IOS



Share this post

Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now