Jump to content
corneliusdavid

Cannot build iOS 15.1 apps

Recommended Posts

I have the following:

  • Delphi 11 on Windows 10 and Windows 11
  • Mac Mini with macOS Monterey 12.0.1 on a 3 GHz Intel Core i5
  • Platform Assistant Server vr. 13.0.12.0
  • iPad and iPhone both running iOS 15.1

 

I've had problems in the linker process trying to get even the simplest bare-bones app to build for iOS. I have no problem with Android or MacOS--it's just iOS. At first, I had an error finding the /System/Library/PrivateFrameworks directory. Looking through the SDK Manager for iPhoneOS 15.0, I found a the Remote Path with that entry and removed it--since it didn't exist on the mace where I found other framework folders. Now I get the following error:

 

[DCC Error] E2597 ld: file not found: /System/Library/PrivateFrameworks/DocumentManager.framework/DocumentManager for architecture arm64

I cannot figure out why it tries to link that file and why, if it expects it, that directory does not exist on the Mac--like I mentioned, other "framework" folders exist. I've removed and re-added the iOS platform looked through the .dproj, and refreshed cached SDK files.  I've got this problem on two different computers and have run out of ideas--and patience.

 

Anyone have any suggestions?

Share this post


Link to post

CanIUse: Monterey

 

Nope :classic_sad:

 

I had a similar Problem (under BigSur), with DocumentManager.

A complete clearing of the SDK's in SdkManager and folders in Delphi, and a new addition to the SDK-Manager with Update local cache helped with that.

But I don't know if that is also true for Monterey.

Edited by Rollo62

Share this post


Link to post
7 hours ago, Rollo62 said:

A complete clearing of the SDK's in SdkManager and folders in Delphi, and a new addition to the SDK-Manager with Update local cache helped with that.

I've tried that. I removed the iOS platform from Delphi, deleted the folders, did a total clean of the project (and also tried a brand new project), re-added the platform which re-added the SDK folders...  Still got same linker error.

 

7 hours ago, Rollo62 said:

CanIUse: Monterey

 

Nope :classic_sad:

So this is a problem with Monterey? Doesn't Delphi import the libraries and frameworks from Xcode? I can build a bare-bones Xcode project on Monterey to my iPhone. 

Share this post


Link to post

it seems , with monterey, passerver import some corrupted files or missing something. 

macOs and iOs develop, building and debug are ko.

 

only solution, today, is to downgrade to BugSur.

  • Like 1

Share this post


Link to post

I have a similar problem. I'm using Delphi 10.4.2 and have done an SDK update to version 15.2.
I am using a server in MacInCloud with macOS Monterey to compile.

During compilation I get the following error. 


[DCC Error] E2597 ld: warning: directory not found for option '-FC:UserDocumentsEmbarcaderoStudioSDKsSystemLibraryPrivateFrameworksDocumentManager.framework'
  ld: file not found: /usr/lib/system/libcache.dylib for architecture arm64
[DCC Fatal Error] F2588 Linker error code: 1 ($00000001)

What can be done about it ?

 

Share this post


Link to post

I'm afraid in this case your Delphi version might be outdated.

Share this post


Link to post

Hi,

 

Having issues here too, Delphi 11 with November and January Patches installed.

PAServer version 13.0.12.1

Mac With Monterey OS 12.2 installed.

iPhone 6s iOS version 15.3

XCode version 13.2.1

 

I am getting the demo MasterDetailApplication app to install but fails with the error - Project MasterDetailApplication raised exception class 6.

 

Any suggestions please?

Update - rebooted everything, again, and this morning it works! 

 

Edited by dazstrong
update

Share this post


Link to post

Any updates on this?  I have a blank application that I can compile to the mac but when trying the ios I get the error

 

DCC Error] E2597 ld: warning: directory not found for option '-FC:\Users\admin\Documents\Embarcadero\Studio\SDKs\iPhoneOS15.2.sdk\System\Library\PrivateFrameworks'

 

I tried above including removing all SDKs and re-installing them.  My issue seems to be that PrivateFrameworks is not installed as it was in older SDKs.

 

Delphi 11 with November and January Patches installed.
PAServer version 13.0.12.2
Mac With Monterey OS 12.2.1 installed.
iPhone iOS version 15.3
XCode version 13.2.1

Share this post


Link to post

In case anyone has same issues with this.  Dave Nottage pointed out to me that at least in my case the problem seemed to be the cache-dir-XXXX folders on the Mac.  Once I deleted them and re-imported all was fine.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×