Jump to content
PeterPanettone

Delphi 11 November Patch

Recommended Posts

I downloaded the Delphi 11 NovemberPatch from https://my.embarcadero.com and executed patch.R110.hotfix.november_install.bat.

This time there were no error messages. (The previous first patch about a month ago produced error messages when installed from GetIt).

I made sure to execute the patch not from a network drive and from a path with no spaces in the path.

I also made sure the Delphi 11 IDE was not running while installing the patch (as it is the case when installing the patch from GetIt).

As seen from the console window, a lot of files were replaced/added.

IMO, there should be a list of applied patches in the About dialog.

 

https://blogs.embarcadero.com/rad-studio-11-alexandria-november-patch-available

Edited by PeterPanettone

Share this post


Link to post

The patch was not suggested on the Welcome screen, nor was it promoted on the default GetIt Package Manager screen. I expected it to be.

 I found the patch under "Patches and Hotfixes" on the GetIt Package Manager screen. I installed it with no errors.

However, I LOST ALL OF MY TOOLBAR CUSTOMIZATIONS.  (Yes, I'm shouting.)

Years ago I gave up using the Delhi Migration Tool because it also failed to preserve my toolbars.  I concluded then that Emb is unable or unwilling to fix whatever problem exists with preserving IDE toolbars during installations.

It appears that the same problem exists on this update, although it's possible of course that the loss I experienced was due to some other coincidental factor than installing the patch.

Edited by Tom F

Share this post


Link to post

it appeared for me on the welcome screen and installed with no issues through GetIt

luckily I do not yet have any toolbar customisations. So no shouting here.

 

Seems an annoying problem which should be raised if not and fixed. 

Share this post


Link to post

My tool bar customisations won't stay between different IDE restarts. eg. Add some extra buttons (using the tool bar customisation) and then close the IDE and restart and they are not there. This is very frustrating. I gather that this is a known issue but won't be fixed until 11.1. It's a major inconvenience (I am well behaved and resisting the very strong urge to shout).

Share this post


Link to post
17 hours ago, Tom F said:

The patch was not suggested on the Welcome screen, nor was it promoted on the default GetIt Package Manager screen. I expected it to be.

Same here. I repeatedly closed the Welcome screen and opened it again with no luck.

After I restarted the IDE it showed up though.

 

A bug ???

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×