Jump to content
Sign in to follow this  
Der schöne Günther

Does C++ Builder have code completion?

Recommended Posts

It's been a few years since I last did something with C++ Builder.


I just freshly installed 10.4. I created a new project from scratch. It compiles on Win32 and Win64, but there is no code completion, [Ctrl]+[Space] does nothing at all.


I see that

C++Builder and Platforms Support - Embarcadero Blogs - Developer Tools - IDERA Community

states Embarcadero strives to provide a "fully functional code completion". Does that mean that there is at least a partly functional code completion? If yes, how can I enable it?

Share this post

Link to post

If you turn on the old compiler for the project it will work again.


Under 10.4.1 it works for the new compiler when you don't batch compile.


If your on subscription they now have Twin Compile GetIt plugin that with my testing works with code completion and super fast compile of big projects.


Amazing that they allow now that to be installed for Pro as well but need subscription to download that, well else buy it.


From 10.1.2 was the last edition Code Completion worked well, truly a poor effort by EMB on this.

  • Thanks 1

Share this post

Link to post

Thank you.


Crazy I just missed the right version. With 10.4.1 instead of 10.4 it would have worked. That's a shame, as I don't have enough hard disk space for yet another RAD Studio VM.

Share this post

Link to post
34 minutes ago, David Millington said:

will be much better in 10.4.2 - lots of work going into it in this release

Good decision.

Nonworking LSP and all related stuff is the biggest time killer for me at the moment, I'm looking forward to a behaviour as smooth as VsCode.


Waiting for the day when Ctrl+Space, Ctrl+Enter, ErrorInside, debug variables, etc. works 100% reliable.

Share this post

Link to post

Been non-functioning for so many years even with the Nov 2020 roadmap you've lost so many users and confidence on this its crazy.

We have wasted thousands and not been able to use the product and loss of functionality has been huge as well.

Share this post

Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this