Jump to content
Coniah

Delphi 10.4.2 first impressions

Recommended Posts

18 minutes ago, Lars Fosdal said:

I did some random spot checks in our code, and typing partial variable name[ctrl+space] or variable[dot] produces a selection very quickly.

Or no, sorry. I meant another scenario:

  • Type partial name like "Canv"
  • Press Ctrl+Space to open drop-down list
  • Select "Canvas" (do not press Enter, just select the item in the list with Up/Down keys)
  • Press '.' (dot) character

You should see 'Canvas.' in the editor. But I get only 'Canv.' instead.

Share this post


Link to post
Guest
Posted (edited)
32 minutes ago, FredS said:

Do you see the HelpInsight window come up, Including the Summary text?

in a "flash" yes!

 

image.png.fd6b0298e732d5c5f247be255ddca114.png

 

hug

Edited by Guest

Share this post


Link to post
2 minutes ago, balabuev said:

Or no, sorry. I meant another scenario:

  • Type partial name like "Canv"
  • Press Ctrl+Space to open drop-down list
  • Select "Canvas" (do not press Enter, just select the item in the list with Up/Down keys)
  • Press '.' (dot) character

You should see 'Canvas.' in the editor. But I get only 'Canv.' instead.

Ah, ok - I never really used it that way.  That behaviour is consistent with what I see.
So, [dot] used to double as [enter] before?

Share this post


Link to post
9 minutes ago, Lars Fosdal said:

don't know the intimate details

Why should you care? Aren't you a paying customer?
When a bug stops one of your customers does he care how complex that is for you to find?

 

Let's be clear here; I've watched plenty of good developers both find the bugs and supply workarounds which where never implemented..

How nice would that be if your clients had to both find it, explain it in detail and fix it for you?

Share this post


Link to post
Posted (edited)
6 minutes ago, Lars Fosdal said:

So, [dot] used to double as [enter] before?

 

Yes. In previous IDE versions I can type the whole line like this without pressing Enter at all:

Canvas.Brush.Color := clRed;

 

Edited by balabuev

Share this post


Link to post

@FredS
My customers also must deal with the bugs that me and the team creates, and we are dependent on them to provide a reproducible bug for us to fix the problem.
Complex software will be complex.

Share this post


Link to post
Guest
Posted (edited)
8 minutes ago, Lars Fosdal said:

You should see 'Canvas.' in the editor. But I get only 'Canv.' instead.

this can be reproduced here, on RAD10.4.2 --- but in RAD 10.3.3 works as expected = Self.Canv (DOT) =  "Self.Canvas." !

valid for another entry... like (Self.)  -> "Sel (DOT) =  Sel. - in fact, any entry is "trucated"!

 

hug

Edited by Guest

Share this post


Link to post
4 minutes ago, balabuev said:

 

Yes. In previous IDE versions I can type the whole line like this without pressing Enter at all:


Cannvas.Brush.Color := clRed;

 

Is there a QP for this? I'd be happy to vote it up.

Share this post


Link to post

image.thumb.png.7e1fff93f15ede2cd596b6d64d02d44d.png

 

Could it be that you have unchecked the "Finish incomplete properties"?  Works here as expected.

  • Like 1

Share this post


Link to post
2 minutes ago, pyscripter said:

Could it be that you have unchecked the "Finish incomplete properties"

No. It's checked (in both LSP and Classic modes).

Share this post


Link to post

I've found the reason. Auto invoke need to be unchecked. Don't know now, whether it is my fail or Auto invoke was checked by default.

  • Like 4

Share this post


Link to post
Posted (edited)
6 minutes ago, balabuev said:

I've found the reason. Auto invoke need to be unchecked

This makes sense.  "Finish incomplete properties" can be very annoying when combined with "Auto invoke" so it is disabled.

Edited by pyscripter

Share this post


Link to post
26 minutes ago, pyscripter said:

This makes sense.

Maybe. I do not use Auto invoke mode personally. Imho, this mode requires even more key presses than manual invoke mode. But, this is another story, not related to 10.4.2.

 

Anyway, Finish incomplete properties check box should be disabled when Auto invoke is checked. Otherwise, it's confusing.

 

Btw, Auto invoke does not work for me in LSP mode. Probably, this was another source of confusion.

Share this post


Link to post
On 2/28/2021 at 12:35 PM, Darian Miller said:

I assume everyone running VirtualBox with 10.4.2 will get this error with no workaround?

If so, that is a full stop for my needs.

Share this post


Link to post
5 hours ago, emailx45 said:

VM with MSWindows 10 64bits - 4GB RAM and 256MB Video by VirtualBox

I am on VBox 6.1.18, and the settings offers only a max of 128MB. How are you getting 256MB?

Share this post


Link to post
Guest
Posted (edited)
1 hour ago, Bill Meyer said:

I am on VBox 6.1.18, and the settings offers only a max of 128MB. How are you getting 256MB?

YAHOOOO! my first spoiler!!! ... say, my second! the first was on my thread about "spoiler" :classic_cheerleader:

 

 

 


image.thumb.png.98734e2250351ae26aa85358485e4c58.png
 

 

 

thanks @Daniel

 

hug

Edited by Guest

Share this post


Link to post

So does this mean that the Extension Pack for VBox is needed to run 10.4.2? I don't see any notes in the installation page about extraordinary video requirements.

Share this post


Link to post
Guest
Posted (edited)
4 minutes ago, Bill Meyer said:

Extension Pack for VBox is needed to run 10.4.2?

NOT! the Extended Pack VBox is for use advanced resources in your VM, like: VGA, Folder Sharing, CPU Virtualization, etc... not relationed to RAD!

https://www.virtualbox.org/manual/ch01.html#intro-installing

 

hug

Edited by Guest

Share this post


Link to post

Support for DirectX11 is required by RAD Studio. This extension-pack might make this difference.

Share this post


Link to post
Guest
Posted (edited)
4 minutes ago, Daniel said:

Support for DirectX11 is required by RAD Studio. This extension-pack might make this difference.

for sure, as I said: advanced resources! but if you dont use FireMonkey or dont need DirectX or another, you can create your project VCL without problem!

Include, I only installed my Extended Pack later @Darian Miller posts (RAD 10.4.2 in VM of course)

 

hug

Edited by Guest

Share this post


Link to post

Read the installation notes. The IDE itself has that requirement.

Share this post


Link to post
Guest
Posted (edited)
2 minutes ago, Daniel said:

Read the installation notes. The IDE itself has that requirement.

not problem, @Daniel but same without it, I have use RAD 10.4.2 in my VM and compile the projects tests VCL

of course, MSWindows 10 came "basic Dx" with it or not?

 

hug

Edited by Guest

Share this post


Link to post
8 minutes ago, Daniel said:

Support for DirectX11 is required by RAD Studio. This extension-pack might make this difference.

Will have to experiment, I guess. There is no mention of DirectX11 in the VBox manual.

Share this post


Link to post
Guest
Posted (edited)
1 minute ago, Bill Meyer said:

Will have to experiment, I guess. There is no mention of DirectX11 in the VBox manual.

Install the Extend Pack, copy the DirectX redistribute for its VM and install! it works!

some software dont execute using "Folder Sharing", then, you need copy for VM!

ISO files, not needs copy! Just register in your VM a CD drive appoint to your ISO and ready!

 

hug

Edited by Guest

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×