Jump to content
Lars Fosdal

Your RAD Studio 10.4 Sydney issues

Recommended Posts

Feel free to post a QP link to issues that cause you problems in 10.4 and that you think that other users need to be aware of.

 

For things you love about the new version, see this thread!

 

You can also vote on your current experience here

 

Share this post


Link to post

Feel free to create one. 🙂

Share this post


Link to post

Hopefully, this could be a short thread.


This report shows the last thirty days of RAD Studio reported issues.

At the time of posting, 31 has been created today.
https://quality.embarcadero.com/secure/ConfigureReport.jspa?projectOrFilterId=project-10000&periodName=daily&daysprevious=30&selectedProjectId=10000&reportKey=com.atlassian.jira.plugin.system.reports%3Arecentlycreated-report&Next=Next

  • Like 1

Share this post


Link to post
Posted (edited)

The issue "Firemonkey form has no animation on minimizing and maximizing in Windows 10." was submitted like 20 times.

That means there are duplicates, a lot of duplicates...

Edited by toms
  • Like 1

Share this post


Link to post

For years I used the ISO because I seemed to have problems with the web install.

I know this release is supposed to unify the two installers and eliminate problems.

However, I still used the ISO.

And then I couldn't get GetIt to work to download CodeSite, etc. 

I asked about this at the GoToMeeting just now.  I needed to RTFM. 🙂

Be sure to read the release notes (http://docwiki.embarcadero.com/RADStudio/Sydney/en/Release_Notes) which state:
 

Quote

If you use the offline installer, RAD Studio will not be able to access the GetIt Package Manager until you manually switch to "online mode". To do this, we recommend using the GetItCmd.exe tool: GetItCmd.exe -c=useonline

 

  • Like 3
  • Thanks 1

Share this post


Link to post
Posted (edited)

Just installed it, and created a new VCL application project.

Launched the debug (F9) and after closing the VCL application, it throws error

 

image.thumb.png.e38441bb0edf85faf9eb6c2b08d36080.png

 

Complete Error log is:

[206C0D7B]{coreide270.bpl} Desktop.TDesktopStates.RestoreDesktop (Line 1713, "Desktop.pas" + 8) + $14
[206C1938]{coreide270.bpl} Desktop.TDesktopState.SaveRuntimeInfo (Line 1935, "Desktop.pas" + 0) + $C
[206C0D62]{coreide270.bpl} Desktop.TDesktopStates.RestoreDesktop (Line 1712, "Desktop.pas" + 7) + $0
[206C13E6]{coreide270.bpl} Desktop.TDesktopStates.ProcessTerminated (Line 1818, "Desktop.pas" + 2) + $12
[20850478]{coreide270.bpl} DebuggerMgr.TProcessEvent.Send (Line 716, "DebuggerMgr.pas" + 2) + $14
[20854E34]{coreide270.bpl} DebuggerMgr.TDebuggerMgr.ProcessStateChanged (Line 2606, "DebuggerMgr.pas" + 8) + $E
[2037386A]{dbkdebugide270.bpl} Debug.TDebugger.DoNotifyProcessStateChanged (Line 11425, "Debug.pas" + 2) + $18
[21067FC9]{designide270.bpl} ToolUtils.ForEach (Line 100, "ToolUtils.pas" + 5) + $F
[203737C9]{dbkdebugide270.bpl} Debug.TDebugger.NotifyProcessStateChanged (Line 11417, "Debug.pas" + 27) + $22
[20375E09]{dbkdebugide270.bpl} Debug.TDebugger.ProcessDestroyedCallback (Line 12098, "Debug.pas" + 4) + $11
[2036FEAE]{dbkdebugide270.bpl} Debug.TProcess.SetProcessState (Line 9739, "Debug.pas" + 4) + $A
[2036E7C5]{dbkdebugide270.bpl} Debug.TProcess.ntfyProcGone (Line 8975, "Debug.pas" + 6) + $4
[2036E856]{dbkdebugide270.bpl} Debug.TProcess.ntfyThreadGone (Line 9007, "Debug.pas" + 20) + $2
[302D669D]{bordbk270N.dll} Unknown function at @isDbkLoggingOn$qv + $2B825
[302E48E2]{bordbk270N.dll} Unknown function at POSTEDHOOKPROC + $3A6E
[302E490F]{bordbk270N.dll} Unknown function at POSTEDHOOKPROC + $3A9B
[302E48E2]{bordbk270N.dll} Unknown function at POSTEDHOOKPROC + $3A6E
[302E490F]{bordbk270N.dll} Unknown function at POSTEDHOOKPROC + $3A9B
[302E5017]{bordbk270N.dll} Unknown function at POSTEDHOOKPROC + $41A3
[302E4FAB]{bordbk270N.dll} Unknown function at POSTEDHOOKPROC + $4137
[302DFCB3]{bordbk270N.dll} Unknown function at @isDbkLoggingOn$qv + $34E3B
[302B23A6]{bordbk270N.dll} Unknown function at @isDbkLoggingOn$qv + $752E
[302DF5DD]{bordbk270N.dll} Unknown function at @isDbkLoggingOn$qv + $34765
[302CC670]{bordbk270N.dll} Unknown function at @isDbkLoggingOn$qv + $217F8
[302CC657]{bordbk270N.dll} Unknown function at @isDbkLoggingOn$qv + $217DF
[302B86A5]{bordbk270N.dll} Unknown function at @isDbkLoggingOn$qv + $D82D
[302E8082]{bordbk270N.dll} Unknown function at POSTEDHOOKPROC + $720E
[50CFBDBA]{vcl270.bpl  } Vcl.Controls.TWinControl.DefaultHandler (Line 10464, "Vcl.Controls.pas" + 30) + $19
[302AEDA6]{bordbk270N.dll} Unknown function at @isDbkLoggingOn$qv + $3F2E
[302CBCFB]{bordbk270N.dll} Unknown function at @isDbkLoggingOn$qv + $20E83
[302CBF95]{bordbk270N.dll} Unknown function at @isDbkLoggingOn$qv + $2111D
[302CD831]{bordbk270N.dll} Unknown function at @isDbkLoggingOn$qv + $229B9
[302AEDA6]{bordbk270N.dll} Unknown function at @isDbkLoggingOn$qv + $3F2E
[302CD177]{bordbk270N.dll} Unknown function at @isDbkLoggingOn$qv + $222FF
[50CFBDBA]{vcl270.bpl  } Vcl.Controls.TWinControl.DefaultHandler (Line 10464, "Vcl.Controls.pas" + 30) + $19
[50CF6DC6]{vcl270.bpl  } Vcl.Controls.TControl.WndProc (Line 7480, "Vcl.Controls.pas" + 91) + $6
[50064541]{rtl270.bpl  } System.@FinalizeArray (Line 32995, "System.pas" + 24) + $6
[50F4D17E]{vcl270.bpl  } Vcl.Styles.TStyleEngine.HandleMessage (Line 3598, "Vcl.Styles.pas" + 22) + $B
[50DF39C0]{vcl270.bpl  } Vcl.Themes.TStyleManager.HandleMessage (Line 5662, "Vcl.Themes.pas" + 11) + $11
[50CFBDBA]{vcl270.bpl  } Vcl.Controls.TWinControl.DefaultHandler (Line 10464, "Vcl.Controls.pas" + 30) + $19
[50CF76DA]{vcl270.bpl  } Vcl.Controls.TControl.WMMouseMove (Line 7712, "Vcl.Controls.pas" + 8) + $22
[50CF6DC6]{vcl270.bpl  } Vcl.Controls.TControl.WndProc (Line 7480, "Vcl.Controls.pas" + 91) + $6
[50CF6A00]{vcl270.bpl  } Vcl.Controls.TControl.Perform (Line 7258, "Vcl.Controls.pas" + 10) + $8
[5006EFFF]{rtl270.bpl  } System.Types.TRect.Contains (Line 1675, "System.Types.pas" + 1) + $3
[50CFB2C4]{vcl270.bpl  } Vcl.Controls.GetControlAtPos (Line 10143, "Vcl.Controls.pas" + 4) + $13
[50CFB3EE]{vcl270.bpl  } Vcl.Controls.TWinControl.ControlAtPos (Line 10166, "Vcl.Controls.pas" + 13) + $E
[50CFB471]{vcl270.bpl  } Vcl.Controls.TWinControl.IsControlMouseMsg (Line 10184, "Vcl.Controls.pas" + 9) + $2A
[50CF3600]{vcl270.bpl  } Vcl.Controls.FindDragTarget (Line 5030, "Vcl.Controls.pas" + 6) + $1B
[50CFBCAE]{vcl270.bpl  } Vcl.Controls.TWinControl.WndProc (Line 10423, "Vcl.Controls.pas" + 168) + $6
[50CFBDBA]{vcl270.bpl  } Vcl.Controls.TWinControl.DefaultHandler (Line 10464, "Vcl.Controls.pas" + 30) + $19
[50060AB4]{rtl270.bpl  } System.TMonitor.TryEnter (Line 19684, "System.pas" + 10) + $0
[500605D4]{rtl270.bpl  } System.TMonitor.Enter (Line 19345, "System.pas" + 4) + $2
[50060440]{rtl270.bpl  } System.TMonitor.CheckOwningThread (Line 19259, "System.pas" + 2) + $0
[50060762]{rtl270.bpl  } System.TMonitor.Exit (Line 19449, "System.pas" + 1) + $2
[500607BE]{rtl270.bpl  } System.TMonitor.Exit (Line 19471, "System.pas" + 2) + $7
[50CD6FA3]{vcl270.bpl  } Vcl.Graphics.FreeMemoryContexts (Line 7278, "Vcl.Graphics.pas" + 12) + $8
[50CFB230]{vcl270.bpl  } Vcl.Controls.TWinControl.MainWndProc (Line 10120, "Vcl.Controls.pas" + 3) + $6
[50CFB245]{vcl270.bpl  } Vcl.Controls.TWinControl.MainWndProc (Line 10123, "Vcl.Controls.pas" + 6) + $0
[50E5A727]{vcl270.bpl  } Vcl.Forms.TApplication.ProcessMessage (Line 11004, "Vcl.Forms.pas" + 25) + $1
[50E5A74A]{vcl270.bpl  } Vcl.Forms.TApplication.ProcessMessages (Line 11024, "Vcl.Forms.pas" + 1) + $4
[004ABBB7]{bds.exe     } AppMain.TAppBuilder.ApplicationActivated (Line 2579, "AppMain.pas" + 0) + $7
[50EBE3B7]{vcl270.bpl  } Vcl.AppEvnts.TCustomApplicationEvents.DoActivate (Line 204, "Vcl.AppEvnts.pas" + 1) + $16
[50EBEA19]{vcl270.bpl  } Vcl.AppEvnts.TMultiCaster.DoActivate (Line 425, "Vcl.AppEvnts.pas" + 5) + $10
[50E59C1F]{vcl270.bpl  } Vcl.Forms.TApplication.WndProc (Line 10591, "Vcl.Forms.pas" + 126) + $C
[50181184]{rtl270.bpl  } System.Classes.StdWndProc (Line 17989, "System.Classes.pas" + 8) + $0
[50E5A71F]{vcl270.bpl  } Vcl.Forms.TApplication.ProcessMessage (Line 11002, "Vcl.Forms.pas" + 23) + $1
[50E5A762]{vcl270.bpl  } Vcl.Forms.TApplication.HandleMessage (Line 11032, "Vcl.Forms.pas" + 1) + $4
[50E5AA95]{vcl270.bpl  } Vcl.Forms.TApplication.Run (Line 11170, "Vcl.Forms.pas" + 26) + $3
[0051E104]{bds.exe     } bds.bds (Line 222, "" + 13) + $2

This error appears on each project I tried.

BTW: IDE Layouts don't apply correctly, either they remain at Debug layout mode after it ends debugging (after this error).

Creating or opening a project keeps the Layout at <none>.

Opening a .dpk (package) project, it remains showing the Welcome Page, I have to manually switch to Default Layout in order to see the package project files to install it.

In case it has something to do, I just updated to Windows 10 version 2004 May Update 2020, before installing it I uninstalled Delphi 10.4 and reinstalled after updating Windows 10 (1909 to 2004). Previously installation (first installation), this error was not present. Sorry my bad english.

Edited by vhanla
  • Sad 1

Share this post


Link to post

This thread should not be used to report your errors but only to post links to the Quality Portal for issues you want others to be aware of.

  • Like 3
  • Thanks 3

Share this post


Link to post

@vhanla - create your report in qualityportal. This not an Idera site, so just writing about it here will not be helpful. 

  • Like 4

Share this post


Link to post

The dark theme is not saved between restarts, I have installed in two different machines.

Share this post


Link to post
1 hour ago, Josa said:

The dark theme is not saved between restarts, I have installed in two different machines.

There is an option (checkbox) that the theme follows the Windows theme. Try to switch that off.

  • Like 1

Share this post


Link to post

Maybe its just I missed something? On initial offline install it looks like I didn't check Help or TeeChart. To get these installed the setup requires me to uninstall the whole thing and start again 😞

Share this post


Link to post

Error opening IDE after using Migration tool to import old settings
https://quality.embarcadero.com/browse/RSP-29126

Used 10.4 Migration tool.
Imported Editor Settings ONLY from 10.3.3.

Started 10.4 Delphi personality
List Index out of range
Interface not supported
OK, OK
Access Violation
OK
IDE Closes without having opened.

The same thing happens again if you start the IDE again.

 

Workaround:

RegEdit: Computer\HKEY_CURRENT_USER\Software\Embarcadero\BDS\21.0\Editor\Options\

 

Remove "Known Editor Enhancements"

 

  • Like 1
  • Sad 1

Share this post


Link to post

I don't know if this is happening only to me, but it is already the second computer that I install Delphi 10.4 and the same problem occurs. I retry with the patch1 and again the problem occur:

 

Compilations of a simple blank package do not work for Linux64 and OSX64.

 

Workaround: You will need to add the following directories to Library Path:

 

Linux64

C:\Program Files (x86)\Embarcadero\Studio\21.0\binlinux64

 

OSX64

C:\Program Files (x86)\Embarcadero\Studio\21.0\binosx64

Share this post


Link to post

So I started to experiment with Delphi 10.4. When we switched to 10.3, I immediately installed the VS code color theme (https://blog.grijjy.com/2017/12/29/alternative-dark-editor-themes-for-delphi-10-2-2/) via the Migration Tool as I think it's the most eye-friendly scheme - plus I got used to it already.

My issue is that Delphi 10.4 simply does not want to accept this. I tried to manually update the values in Registry but as soon as the IDE restarts they are being overwritten. Does anyone know where Delphi 10.4 stores the saved color schemes? I would try to create a new one and set it as a default for my dark theme; I just don't know where to put them 🙂

Share this post


Link to post
2 minutes ago, aehimself said:

So I started to experiment with Delphi 10.4. When we switched to 10.3, I immediately installed the VS code color theme (https://blog.grijjy.com/2017/12/29/alternative-dark-editor-themes-for-delphi-10-2-2/) via the Migration Tool as I think it's the most eye-friendly scheme - plus I got used to it already.

My issue is that Delphi 10.4 simply does not want to accept this. I tried to manually update the values in Registry but as soon as the IDE restarts they are being overwritten. Does anyone know where Delphi 10.4 stores the saved color schemes? I would try to create a new one and set it as a default for my dark theme; I just don't know where to put them 🙂

There is new option in Options -> User Interface -> Theme Manager called Toggle style to match Windows Light and Dark mode. It is checked by default and that setting overrides any other custom settings. You need to uncheck that option before you can use custom theme settings.

 

If you want to edit registry directly under Theme key, this new option is called ToggleTheme (DWORD) and its value should be set to 0

Share this post


Link to post
2 minutes ago, Dalija Prasnikar said:

There is new option in Options -> User Interface -> Theme Manager called Toggle style to match Windows Light and Dark mode. It is checked by default and that setting overrides any other custom settings. You need to uncheck that option before you can use custom theme settings.

 

If you want to edit registry directly under Theme key, this new option is called ToggleTheme (DWORD) and its value should be set to 0

By mistake I already discovered this option and disabled it. It shows as off in Dephi IDE and ToggleTheme in Registry values stores 0. Still, color values in Editor \ Highlight \ * are being reset to the values of the scheme selected.

Share this post


Link to post
1 minute ago, aehimself said:

By mistake I already discovered this option and disabled it. It shows as off in Dephi IDE and ToggleTheme in Registry values stores 0. Still, color values in Editor \ Highlight \ * are being reset to the values of the scheme selected.

This might be a bug, then. I just found one similar to what you are describing 

 

IDE does not remember user color seting for source editor

https://quality.embarcadero.com/browse/RSP-28754

  • Like 1

Share this post


Link to post

What I did to get my favorite color scheme from 10.3 to 10.4 and have it stick.

 

In 10.4, go to Options | User Interface | Editor | Color

With the current colors, just click on [Save As] and and give your personal scheme a name.  I called mine Lars.

This creates a Registry branch, named HKEY_CURRENT_USER\Software\Embarcadero\BDS\21.0\Editor\Highlight\Custom themes\Lars

 

In RegEdit, go to HKEY_CURRENT_USER\Software\Embarcadero\BDS\20.0\Editor\Highlight (i.e. the Rio branch)

Export to a file, f.x. MyColors.reg

 

In MyColors.reg, you'll see

Windows Registry Editor Version 5.00
[HKEY_CURRENT_USER\Software\Embarcadero\BDS\20.0\Editor\Highlight]
[HKEY_CURRENT_USER\Software\Embarcadero\BDS\20.0\Editor\Highlight\Additional search match highlight]
... and so on

Now, Open MyColors.reg in Notepad, search for "20.0\Editor\Highlight\" and replace it with "21.0\Editor\Highlight\Custom themes\Lars\".

Add the two branch paths for good measure.

Windows Registry Editor Version 5.00
[HKEY_CURRENT_USER\Software\Embarcadero\BDS\21.0\Editor\Highlight]
[HKEY_CURRENT_USER\Software\Embarcadero\BDS\21.0\Editor\Highlight\Custom themes]
[HKEY_CURRENT_USER\Software\Embarcadero\BDS\21.0\Editor\Highlight\Custom themes\Lars]
[HKEY_CURRENT_USER\Software\Embarcadero\BDS\21.0\Editor\Highlight\Custom themes\Lars\Additional search match highlight]
... and so on

Import the file into the registry, Restart the 10.4, go to Options | User Interface | Editor | Color and pick the custom theme "Lars".

  • Like 6

Share this post


Link to post

This was my plan all along, I just did not see the "Custom themes" subkey 🙂 Thank you, @Lars Fosdal; this method works like a charm!

  • Like 1

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×