Jump to content
Darian Miller

RAD Studio 11 Alexandria is now available

Recommended Posts

3 minutes ago, Darian Miller said:

The formatter is old tech

Irrelevant. Good products are cohesive. Different aspects work with each other and support each other. 

 

3 minutes ago, Darian Miller said:

given the pace of new features

Funny. Binary literals, digit separators and avx512 asm. That's the entirety of new language features. That's a pace that can only be described as glacial.

 

Cant be hard to get the old formatter to work. If it's an arse for them to do it, tough. Their adult for building up so much technical debt.

 

Honestly, look at the quality of what comes out of Emba and compare to other mainstream IDEs.

Edited by David Heffernan
  • Like 5
  • Haha 4

Share this post


Link to post

A happy man. There is no change for me.

Share this post


Link to post

The installation now works for me, I've received a response from Embarcadero support, I paste below:

 

This is a known issue that we have resolved earlier today. Please follow these steps to resolve the license error:

In the Product Registration window please select the Advanced button
- The Embarcadero License Manager will Launch
- In the License Manager please click the Delete button to delete your license
- Click the Register button and re-register your license
- Click Done and this will continue the installation.


For isolated or offline machines you will need to obtain a new activation file from https://license.embarcadero.com/srs6/activation.do

 

Share this post


Link to post
2 minutes ago, David Heffernan said:
5 minutes ago, Darian Miller said:

The formatter is old tech

Irrelevant. Good products are cohesive. Different aspects work with each other and support each other. 

 

It's definitely relevant when you have limited resources and a lot of purchased legacy code.  There's a business decision to be made - keep throwing money at something you know you are going to replace, or not.   They are choosing to add language features knowing that their tooling doesn't fully support it.  

 

I'm sure it's a hard decision.  I'd like to think I would have decided differently but I don't know the internals.  I would assume you would build a well-defined language spec for the current implementation, build the tests to validate that current implementation matches the spec, correct or replace the tooling to support that spec while validating the tools with tests of their own, and then add new features while extending all of your tests.  But that would take a lot of up front effort while yielding no immediate revenue which is probably why they took the path they did.  I should probably be more empathetic to their situation, but at the end of the day CTRL-D doesn't do what CTRL-D is supposed to do.

 

  • Like 2

Share this post


Link to post
1 hour ago, Darian Miller said:

In your ELC - when you visit the Manage Catalog screen, does RS11 show up?

Yes. I just executed Host Licenses to achieve that. Perhaps the license isn't upgraded on the Emba side yet? I had to wait a few minutes after GA, but that might differ for others.

There is also a web link at the bottom of the License Hosting page of ELC where you can get the server license files manually. Beware that it is HTTP and it requires your certificate user name and password, so you might want to change that to HTTPS before.

1 hour ago, Darian Miller said:

Does your License Manager show "Delphi Enterprise" or does it mention 11 Alexandria?

It says Delphi 11.0 Alexandria Architect and C++Builder 11.0 Alexandria Architect .

1 hour ago, Darian Miller said:

"Delphi Enterprise" is what is displayed in my readme_xxxx.txt file - can you confirm what's in yours?

It says RAD Studio 10.2 Tokyo Architect (that was the version I switched to a network license). 

1 hour ago, Darian Miller said:

Delphi 11 Alexandria is listed as a product_name in in the catalog_xxxx.xml.

Well, it says RAD Studio 11 Alexandria, but that seems to be a close match.

  • Thanks 1

Share this post


Link to post
13 minutes ago, Uwe Raabe said:

There is also a web link at the bottom of the License Hosting page of ELC where you can get the server license files manually

 

I tried the manual approach (for the first time) and I compared the results of the two .zip files and there were binary differences so I unzipped the file into .conf and replaced the .zip file there.  This did give me a new "Delphi 11 Alexandria" item in the Manage Catalog screen so that's a step forward over using the "Host Licenses" button in ELC.

 

I also copied the new namedxxx.slip to workstation.  I removed the Beta license with License Manager and imported this slip and when starting RAD Studio and it repeatedly complained of license failure and it wouldn't load.  I figured there was some trace of the now missing Beta key still around so I deleted c:\programdata\embarcadero and re-imported the .slip with license manager.

 

Now, when launching RAD Studio, I get the product registration screen, I hit Cancel, and then No to the "No valid license info found..run the wizard again" screen, "Ok" on the "You are not licensed" screen and then the splash screen continues  with "Registered (using license server)" comment.  I ran with elevated privileges hoping that would cure it, but I still get the registration screens but it does allow me in.

 

So I'm a little closer, thanks.  There's apparently still some traces of an invalid license somewhere.  I'll probably just blow out this VM and do a full re-install with the new .slip from the manual hosting process.

Share this post


Link to post
3 hours ago, Joseph MItzen said:

that's two more things I can cross off my list of 35-45 improvements I wanted that I drew up in 2013.

I am quite satisfied this time. From the issues in QP created by me there are 17 closed as Fixed in Delphi 11. The oldest is from Feb 2017, but most are from 2020 and 2021.

 

Counting over all Delphi versions in QP there are 53 from 78 issues of mine fixed now. Not that bad.

  • Like 7

Share this post


Link to post
3 hours ago, David Heffernan said:

Irrelevant. Good products are cohesive. Different aspects work with each other and support each other.

It's relevant when you're wondering why they can't get it working properly.

I'm not sure but I seem to remember that the formatter was written in J# or some horror like it. Technical debt indeed. Their solution to that appears to be letting those old features rot until everyone has given up on them and then remove them from the product. On that account, the formatter and refactoring features days are numbered.

 

3 hours ago, Darian Miller said:

It's definitely relevant when you have limited resources and a lot of purchased legacy code.  There's a business decision to be made - keep throwing money at something you know you are going to replace, or not.   They are choosing to add language features knowing that their tooling doesn't fully support it.  

Fair enough; We all have to work within the limits of available resources. So let someone else work on those tools that they can't maintain themselves. What's to lose?

 

Anyway, I known very little about LSP but if it can supply a good detailed DOM then I guess one could write a better formatter on top of that with relative ease.

A few years back I looked at writing a formatter, using some of the available Delphi parsers, but none of their DOMs were detailed enough for the purpose.

Share this post


Link to post
5 hours ago, Darian Miller said:

I'll probably just blow out this VM and do a full re-install with the new .slip from the manual hosting process.

 

Finally - everything seems to be working with my network license.  I updated my recent blog post with 3 possible fixes for license issues when installing RAD Studio 11.  ('Update' your license in License Manager, Delete/Re-Import in License Manager, and Manually Host in ELC for network licenses.)

 

https://www.ideasawakened.com/post/quick-fix-for-for-rad-studio-11-license-failure-during-installation

  • Thanks 2

Share this post


Link to post
10 hours ago, esegece said:

Inštalácia teraz funguje pre mňa, dostal som odpoveď od podpory Embarcadero, vkladám nižšie:

 

Toto je známy problém, ktorý sme dnes vyriešili. Na vyriešenie chyby licencie postupujte podľa týchto krokov:

V okne Registrácia produktu zvoľte tlačidlo Rozšírené
- Spustí
sa licenčný manažér Embarcadero - V Správcovi licencií kliknite na tlačidlo Odstrániť, čím odstránite svoju licenciu
- Kliknite na tlačidlo Registrovať a znova sa zaregistrujte. vaša licencia
- Kliknite na Hotovo a bude pokračovať v inštalácii.


V prípade izolovaných alebo offline počítačov budete potrebovať nový aktivačný súbor z  https://license.embarcadero.com/srs6/activation.do

 

Thank you, I'm fine too. To be sure, I removed all licenses. I also had an XE7 there, which I upgraded from.

I'm a lucky person too:classic_cheerleader:I look forward to installing "add-ons" and new issues.

Edited by Stano

Share this post


Link to post
10 hours ago, esegece said:

The installation now works for me, I've received a response from Embarcadero support, I paste below:

 

This is a known issue that we have resolved earlier today. Please follow these steps to resolve the license error:

In the Product Registration window please select the Advanced button
- The Embarcadero License Manager will Launch
- In the License Manager please click the Delete button to delete your license
- Click the Register button and re-register your license
- Click Done and this will continue the installation.


For isolated or offline machines you will need to obtain a new activation file from https://license.embarcadero.com/srs6/activation.do

 

Does this inc the installation counter for 10.4? I'm close to/on the limit.

 

Ole

Share this post


Link to post

Yes, I have install D10.42 and D11. Both run.

Share this post


Link to post
23 hours ago, Sándor Bógáncs said:

I was wondering if anyone had any tricks. I’ve already contacted support, I just can’t wait for them to respond.

You obiously haven't learned yet that this is pretty routine if you're in a super-hurry to install an update as soon as it's released. 

 

I used to enjoy playing with beta code. But these days, I usually won't bother to install a new update until their first patch is released. Just too many problems to be in such a hurry.

  • Like 3

Share this post


Link to post

Hi all,

 

So I had been looking forward to some juicy update for this version of Delphi.

Looking at the roadmap I thought they have this one in the bag for me.

 

2 things I was looking forward to were..

 

1) Delphi Language Extensions for increasingly powerfull coding

2) Math performance improvements to increase your application speed

 

Do these come in the form of later updates...

  • Like 1

Share this post


Link to post
On 9/11/2021 at 4:17 PM, Erix A. said:

The debugger seems to be fixed as now I can see the contents of  TList<> again - https://imgur.com/a/QRgl4Hh (and they closed my report in Jira as well).

Has nothing to do with the debugger but with a refactoring to TList which I suggested: https://quality.embarcadero.com/browse/RSP-34681 (probably cannot see that as it still seems to be marked as beta report)

  • Thanks 4

Share this post


Link to post
On 9/11/2021 at 1:45 PM, Bernard said:

2 things I was looking forward to were..

 

1) Delphi Language Extensions for increasingly powerfull coding

2) Math performance improvements to increase your application speed

 

Do these come in the form of later updates...

We have no idea. New roadmap hasn't been published yet.

Share this post


Link to post
On 9/10/2021 at 7:49 PM, David Heffernan said:

Do mean decimal seps or thousands seps? 

D'uh! Thousands....thanks for pointing that out.🤦‍♂️

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×