Jump to content
Ian Branch

Saving a large project takes soooo Loooonnnnggg..

Recommended Posts

It so happens I have written a tutorial on that exact topic. Here it is:

 

Disabling Live Bindings, The Tutorial

  1. Google "disable live bindings".

[the end]

  • Like 1
  • Haha 2

Share this post


Link to post
Posted (edited)
Quote

Google "disable live bindings"

I think, it was a joke...:classic_unsure: Google: "delphi disable live bindings" site is not funny.

 

the answer is:

Quote

Related post: https://forums.embarcadero.com/message.jspa?messageID=934167

 

And I have just disabled livebinding by renaming all the 4 .bpl files on disk:


dclbindcomp180.bpl
dclbindcompdbx180.bpl
dclbindcompfmx180.bpl
dclbindcompvcl180.bpl

 

Edited by haentschman

Share this post


Link to post

Just checked, those 4 files are named as following in my system:

 

dclbindcomp180_RenamedByEdwin.bpl
dclbindcompdbx180_RenamedByEdwin.bpl
dclbindcompfmx180_RenamedByEdwin.bpl
dclbindcompvcl180_RenamedByEdwin.bpl

:D

Share this post


Link to post
5 hours ago, David Heffernan said:

Type that word into Internet search engine..... 

Well, actually I did, no link directly to a document, but only forum discussions. Never mind though.

Share this post


Link to post

Hi Guys,

I just disabled the BPLs in Delphi.

1.  Go to Component|Install Packages

2.  Disable the LiveBindings packages.  See picture attached.

That's all.

 

Regards,

Ian

Screenshot_1.png

  • Thanks 1

Share this post


Link to post
1 hour ago, Ian Branch said:

I just disabled the BPLs in Delphi.

That typically doesn't stick. For some reason Delphi enables the packages again sooner or later. It's been like that for as long as I can remember.

  • Like 2

Share this post


Link to post

Hi...

Quote

That's all

After the delphi restart the packages are enabled again.

 

Share this post


Link to post

Disabling packages usually works on a per project basis. If you want them to be disabled globally, you might be more lucky disabling them when no project is open.

 

BTW; When I want to permanently get rid of IDE packages I usually remove them in the registry under HKCU and HKLM. The advantage is that this approach also works for packages not available in the Install Packages dialog.

Share this post


Link to post

Hi haentschman,

Not in my case.  I have been in and out of D-Rio multiple times and the libraries/components are still not enabled.

Does it perhaps have something to do with the Saving and Desktop IDE setting?

I have Autosave off for both the available options.

 

There is a Delphi utility around somewhere that allows you to delete Delphi libraries/components, along with a lot of other Delphi related stuff, but I don't recall its name.

Other than that, I have nothing to offer.

Regards,

Ian

Share this post


Link to post
16 hours ago, Darian Miller said:

You can rename the BPL but it's probably best to leave the BPLs alone and just mark them as disabled.  

 

see:

https://wiert.me/2018/08/02/one-more-reason-to-disable-live-bindings-it-throws-exceptions-when-a-project-is-in-a-project-group/

I don't think so. I have the experience that the packages got re-enabled later even I disabled it without any project being opened.

And as opposed to modifying/removing Registry entries, I think renaming the .bpl files seems to be more 'recoverable', because the filenames are obvious and meaningful.

Share this post


Link to post
26 minutes ago, Ian Branch said:

There is a Delphi utility around somewhere that allows you to delete Delphi libraries/components, along with a lot of other Delphi related stuff, but I don't recall its name.

Other than that, I have nothing to offer.

You might be thinking of my KnownIdePackagesManager Tool for Delphi, but that only handles IDE packages, not component packages. It should be easy to exend it to do that too, though.

Share this post


Link to post

Hi Thomas,

Yes, that was one, another was DelphiDistiller, however it hasn't been updated for D-Rio.

Regards,

Ian

Share this post


Link to post
11 hours ago, Anders Melander said:

That typically doesn't stick. For some reason Delphi enables the packages again sooner or later. It's been like that for as long as I can remember.

The package list is specific for the active project. To change the default you have to edit the package list with no project or project group open, and that will still only apply to new projects you create after that.

Share this post


Link to post
Just now, PeterBelow said:

The package list is specific for the active project.

I believe you, but that makes absolutely no sense from a usability perspective.

 

You're saying that the Design packages list in project options is working on the same settings as the Design packages list in the Component, Install Packages dialog (which is where one used to install packages globally).

[checking...] You're right. The dialog even says "Project options". Amazing! :classic_huh:

Share this post


Link to post
4 minutes ago, Anders Melander said:

I believe you, but that makes absolutely no sense from a usability perspective.

 

You're saying that the Design packages list in project options is working on the same settings as the Design packages list in the Component, Install Packages dialog (which is where one used to install packages globally).

[checking...] You're right. The dialog even says "Project options". Amazing! :classic_huh:

Oh, it makes perfect sense. This feature makes it possible to work on a project with only the component packages loaded that this project requires. That reduces the IDE memory print, especially if you have a lot of 3rd-party packages installed (these things tend to breed if you don't look 😉), of which the current project only uses a small subset. That was certainly more important in the early times of Delphi (D1, Win16!) but can still make a difference today.

You can drastically reduce the IDE start time, for example, by using a default package set that is the absolute minimum, basically only what is needed for every project you work on. Other packages are then only enabled for the project that needs them.

  • Like 1

Share this post


Link to post

I'm not saying that the feature doesn't make sense.

I'm saying that it doesn't make sense that these settings can be edited more than one place and that one of the places is the global Components, Install Packages dialog.

After all if I still get confused about this after using Delphi for 24 years, then there's either something wrong with the UI or I'm just slow.

 

Change the global dialog so it doesn't edit the project package list and instead make it clear that it's editing the default options and there's no confusion.

 

Even better, and I remember this was discussed ad nauseam some twenty years ago, but if the package list had been opt-in instead of opt-out then much of these package juggling problems wouldn't exist.

  • Like 5

Share this post


Link to post

In short future this and other IDE performance issues will be resolved ... I hope 🙂

  • Thanks 2
  • Haha 2

Share this post


Link to post
7 hours ago, PeterBelow said:

with no project or project group open

RSP-14289 is still open and a comment suggests it still plays this way in Rio..

Created: 24/Apr/16 4:05 PM
  • Sad 1

Share this post


Link to post
Posted (edited)
On 5/29/2019 at 10:34 AM, Ian Branch said:

Yes, that was one, another was DelphiDistiller, however it hasn't been updated for D-Rio.

The latest version is in the attachment. It supports the latest version of RAD Studio.

 

Edited by Daniel
Attachment removed.

Share this post


Link to post

I removed the attachment.

In earlier versions, this tool also removed any copy protection from Delphi.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×