Jump to content

Recommended Posts

And now comes the long-standing debate we have with ourselves: "Do I take the risk and download it? Or do I wait until some other poor schmoe becomes an unwitting tester"  

I'm soooo tempted to give it a try! 

 

  • Like 5
  • Sad 1

Share this post


Link to post
3 minutes ago, Tom F said:

Or do I wait until some other poor schmoe becomes an unwitting tester

What do you think all the beta testers did during the last weeks?

  • Like 2

Share this post


Link to post
1 minute ago, Uwe Raabe said:

What do you think all the beta testers did during the last weeks?

We have no idea as it's most probably sealed by NDA agreement.

  • Like 5
  • Haha 1

Share this post


Link to post
Quote

What do you think all the beta testers did during the last weeks?

The same thing they always do:  GREAT WORK.   We all owe a lot to them.  THANK YOU, beta testers.

But, as we've seen over the years, releases from EMB still seem to have regressions. No?

  • Like 3

Share this post


Link to post
3 minutes ago, Uwe Raabe said:

What do you think all the beta testers did during the last weeks?

Doing their best to avoid an even bigger disaster? :classic_laugh:

  • Like 4
  • Haha 9
  • Sad 1

Share this post


Link to post

So, literally one and half hour ago we finally switched main branch to Alexandria. And now this...

  • Sad 1

Share this post


Link to post
1 hour ago, Uwe Raabe said:

What do you think all the beta testers did during the last weeks?

Found and reported load of bugs that haven't been fixed and aren't in the public QP. 

  • Like 2
  • Haha 2

Share this post


Link to post
9 minutes ago, David Heffernan said:

Found and reported load of bugs that haven't been fixed and aren't in the public QP. 

At least not up to this day...

Share this post


Link to post
1 hour ago, David Heffernan said:

Found and reported load of bugs that haven't been fixed and aren't in the public QP. 

 

Maybe @Uwe Raabe tried to suggest that the beta testers gained access to the repository and instead of QP they were able to check in solution for all the bugs in Jira.

  • Like 1

Share this post


Link to post
Posted (edited)

  Does it require reinstalling? 

It does. Fuck. 

 

Anyway, yay!

Edited by ioan
  • Sad 1

Share this post


Link to post

Just installed 11.1! The installation ran smoothly ( uninstalling / reinstalling ) I used Web Installer. 
I compiled a few projects successfully. I really want to test the debugger! 11.0 was driving me nuts!!

Share this post


Link to post

I will only point out that unless you delete the registry, all installed add-ons will be preserved.

  • Like 2

Share this post


Link to post
Posted (edited)

Downloaded and installed via the Web Installer.

No Issues.  Had to rebuild a couple of 3rd Party libraries.

Observations thus far..

1.  All add-ins except GetIt add-ins, preserved.

2.  Don't mind the coloured background in the welcome page.

3.  Backward step - I rebuilt 21 projects.  Moving from D10.4.2 to D11, all projects were physically smaller.  From D11 to D11.1, all projects are larger.  Not a biggie but a little surprised.

4.  Getting some access violation errors in vcl280.bpl when exiting - This could be due to other 3rd party libraries att.

5.  Build for the 21 projects took approx 3m 35s in D11.  Approx 3m 49s in D11.1.  This includes EurekaLog processing.

 

I continue to play/investigate.

 

Still hoping for WUPPDI & Bookmarks.  🙂

 

Ian

Edited by Ian Branch

Share this post


Link to post
5 hours ago, Tom F said:

Do I take the risk and download it?

This isn't a "new" version (like 10.4 Sydney over 10.3 Rio), this is an in-place, dot-release update to 11 Alexandria. Yes, it uninstalls your current version 11.0 installation (if you installed it).

 

Strange that the numbering scheme is a little different than the 10.x series (e.g. 10.1 Berlin and 10.0 Seattle).

Share this post


Link to post
Posted (edited)
6 minutes ago, corneliusdavid said:

Strange that the numbering scheme is a little different than the 10.x series (e.g. 10.1 Berlin and 10.0 Seattle).

 

People were confused by previous numbering scheme and plenty of people thought that 10.1, 10.2, 10.3 and 10.4 were just updates not major releases.

 

So current numbering scheme for major releases is full number 11 vas major release and 11.1 is update (there were several patches, but they didn't have separate number) and next major release will be 12. Of course, it is possible that there will be other updates for version 11.

Edited by Dalija Prasnikar

Share this post


Link to post
1 minute ago, Dalija Prasnikar said:

So current numbering scheme for major releases is full number 11 vas major release and 11.1 is update (there were several patches, but they didn't have separate number) and next major release will be 12

Excellent! I like that method much better.

  • Like 1

Share this post


Link to post
32 minutes ago, Dalija Prasnikar said:

plenty of people thought that 10.1, 10.2, 10.3 and 10.4 were just updates not major releases

for sure not just because of the numbers

  • Haha 4

Share this post


Link to post

The Docwiki links for new features and fixes in 11.1 are not working (here).

Share this post


Link to post

I am unable to debug my main project using Rad Studio 11.1 - I get random entry point not found errors(runs fine outside the ide or in Release config, but of course then breakpoints don't work). Embarcadero knew about the error but here we are, yet another version unusable for me. Beyond frustrated. 

  • Haha 1
  • Sad 1

Share this post


Link to post
2 hours ago, Vincent Parrett said:

Embarcadero knew about the error

Can you send the number in QP? I am curious to see the detail.

Share this post


Link to post
3 minutes ago, SwiftExpat said:

Can you send the number in QP? I am curious to see the detail.

I will when they make it public - but much of the discussion happened on a private embarcadero forum.

  • Sad 1

Share this post


Link to post

I posted a new issue since the issue occurs with the release build and my other issue had extra problems that may or may not be related.

 

https://quality.embarcadero.com/browse/RSP-37603

 

I have narrowd this down to the Linking\Debug Information setting - turning that on in the Release config causes the same issue.. seems like a memory corruption issue to me (the app runs fine outside the IDE). 

 

  • Thanks 1
  • Sad 1

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×